- based on openjdk7 b147 and the bsd-port branch as of 20110811. - integrates mozilla rhino 1.7R3 scripting support based on patches from icedtea7 snapshot as of 20110819. - refresh bootstrap kits - tested on NetBSD 5.0/current, i386/amd64 and DragonFlyBSD 2.10 i386. Upstream changes: mostly bugfixes. Perhaps also noteworthy is that the zero assembler port has been integrated which should open up for wider platform support in pkgsrc in the future.
24 lines
774 B
Text
24 lines
774 B
Text
$NetBSD: patch-av,v 1.2 2011/08/21 22:57:55 tnn Exp $
|
|
|
|
--- jdk/make/net/sourceforge/jnlp/Makefile.orig 2011-08-19 21:44:33.000000000 +0000
|
|
+++ jdk/make/net/sourceforge/jnlp/Makefile
|
|
@@ -0,0 +1,19 @@
|
|
+BUILDDIR = ../../..
|
|
+PACKAGE = net.sourceforge.jnlp
|
|
+PRODUCT = jnlp
|
|
+
|
|
+include $(BUILDDIR)/common/Defs.gmk
|
|
+
|
|
+AUTO_FILES_JAVA_DIRS = net/sourceforge/jnlp net/sourceforge/nanoxml netscape
|
|
+LOCALE_SET_DEFINITION = jre
|
|
+
|
|
+OTHER_PROPERTIES += $(PKGDIR)/resources/Messages.properties
|
|
+
|
|
+OTHER_JAVACFLAGS += -classpath $(RHINO_JAR)
|
|
+
|
|
+build: $(CLASSDESTDIR)/$(PKGDIR)/resources/Messages.properties
|
|
+
|
|
+$(CLASSDESTDIR)/$(PKGDIR)/resources/Messages.properties: $(SHARE_SRC)/classes/$(PKGDIR)/resources/Messages.properties
|
|
+ $(install-file)
|
|
+
|
|
+include $(BUILDDIR)/common/Classes.gmk
|