pkgsrc/lang/ocaml/patches/patch-man_Makefile
jaapb 7908506a76 Updated package lang/ocaml to version 4.06.
Changes are many and can be found at https://ocaml.org/releases/4.06.html

One change that breaks a lot of packages is that the safe-string compiler
option is now enabled by default, which means that all modules need to use
immutable strings (or explicitly use the bytes type).
2018-01-10 14:30:34 +00:00

15 lines
569 B
Text

$NetBSD: patch-man_Makefile,v 1.4 2018/01/10 14:30:35 jaapb Exp $
Use BSD_INSTALL_* instead of mkdir and cp
--- man/Makefile.orig 2017-10-03 08:35:24.000000000 +0000
+++ man/Makefile
@@ -18,7 +18,7 @@ include ../config/Makefile
INSTALL_DIR=$(DESTDIR)$(MANDIR)/man$(PROGRAMS_MAN_SECTION)
install:
- for i in *.m; do cp \
+ for i in *.m; do $(BSD_INSTALL_MAN) \
$$i $(INSTALL_DIR)/`basename $$i .m`.$(PROGRAMS_MAN_SECTION); done
echo '.so man$(PROGRAMS_MAN_SECTION)/ocamlc.$(PROGRAMS_MAN_SECTION)' \
> $(INSTALL_DIR)/ocamlc.opt.$(PROGRAMS_MAN_SECTION)