pkgsrc/editors/xemacs/patches/patch-lib-src_Makefile.in.in
hauke e522399242 Update to patch release 21.4.24. From the ChangeLog:
2015-03-24 Vin Shelton <acs@xemacs.org>

        * XEmacs 21.4.24 is released

2015-02-23  Vin Shelton  <acs@xemacs.org>

        * configure.in: Add LIBOSSAUDIO as appropriate.  Patch from netbsd
        via Hauke Fath.
        * configure: Rebuild.

2015-02-15  Vin Shelton  <acs@xemacs.org>

        * configure.in: Additional netbsd platform definitions.
        * configure: Rebuild.

I have used the opportunity for a bit of spring cleaning:

o remove build restrictions for powerpc and mips (hacks.mk, Makefile)
o drop the inactive X11 toolkit options - they were never used, and
  upstream does not support them for 21.4, anyway (options.mk)
o add comments to patch files
o upstream converted the texinfo files to v5 format. Patch the offenders
  to be v4 compatible
2016-04-13 13:52:27 +00:00

43 lines
1.8 KiB
Text

$NetBSD: patch-lib-src_Makefile.in.in,v 1.2 2016/04/13 13:52:27 hauke Exp $
Install selected files, using bsd.pkg.mk functionality
--- lib-src/Makefile.in.in.orig 2015-01-29 15:04:29.000000000 +0000
+++ lib-src/Makefile.in.in
@@ -237,7 +237,7 @@ do-blessmail: $(blessmail)
## Install the internal utilities. Until they are installed, we can
## just run them directly from lib-src.
-${archlibdir}: all
+install-archlibdir: all
@echo; echo "Installing utilities run internally by XEmacs."
./make-path ${archlibdir}
if test "`(cd ${archlibdir} && $(pwd))`" != "`$(pwd)`"; then \
@@ -248,17 +248,23 @@ ${archlibdir}: all
if test "`(cd ${archlibdir} && $(pwd))`" \
!= "`(cd ${srcdir} && $(pwd))`"; then \
for f in ${PRIVATE_INSTALLABLE_SCRIPTS}; do \
- (cd .. && $(INSTALL_PROGRAM) ${srcdir}/$$f ${archlibdir}/$$f); \
+ (cd .. && $(BSD_INSTALL_SCRIPT) ${srcdir}/$$f ${archlibdir}/$$f); \
done ; \
fi
-install: ${archlibdir}
+install: install-archlibdir
@echo; echo "Installing utilities for users to run."
for file in ${PUBLIC_INSTALLABLE_EXES} ; do \
- (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
+ if test $${file} = etags || test $${file} = ctags || test $${file} = b2m ; then \
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/xemacs-$${file}) ; else \
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
+ fi \
done
for file in ${PUBLIC_INSTALLABLE_SCRIPTS} ; do \
- (cd .. && $(INSTALL_PROGRAM) ${srcdir}/$${file} ${bindir}/$${file}) ; \
+ if test $${file} = rcs-checkin || test $${file} = send-pr ; then \
+ (cd .. && $(BSD_INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/xemacs-$${file}) ; else \
+ (cd .. && $(BSD_INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file}) ; \
+ fi \
done
uninstall: