pkgsrc/devel/ncurses/patches/patch-ad
adam 3eaefbdf01 Changes 5.6:
Hashed-databases are supported for storing terminal descriptions.
Support for magic-cookies such as hpterm was improved.
Support for rpath in shared libraries was revised.
Many bugfixes were made for memory leaks, wide-character support, portability,
  and more.
2007-01-08 11:01:05 +00:00

13 lines
448 B
Text

$NetBSD: patch-ad,v 1.10 2007/01/08 11:01:05 adam Exp $
--- c++/Makefile.in.orig 2006-10-21 19:07:49.000000000 +0200
+++ c++/Makefile.in
@@ -154,7 +154,7 @@ LIB_OBJS = \
../lib/$(LIBNAME_LIBTOOL) : $(LIB_OBJS)
cd ../lib && $(LIBTOOL_LINK) $(CXX) $(CXXFLAGS) \
- -o $(LIBNAME) $(LIB_OBJS:$o=.lo) \
+ -o $(LIBNAME) $(LIB_OBJS:.o=.lo) \
-rpath $(INSTALL_PREFIX)$(libdir) \
-version-info $(NCURSES_MAJOR):$(NCURSES_MINOR) $(SHLIB_LIST)