a62b3e67a6
With apologies to Al I wouldn't know where to start with a summary of the changes between 2.1 and 2.2.1 - there are just too many. A couple of hopefully static URLS that contain useful information are http://www.kde.org/announcements/changelog2_1to2_2.html http://www.kde.org/announcements/changelog2_2to2_2_1.html Support for a.out for kde{libs,base} added by me. The libtool/a.out combination doesn't like the linking of modules into binaries. A better way of doing this will appear in future versions of KDE/pkgsrc.
41 lines
1.2 KiB
Text
41 lines
1.2 KiB
Text
$NetBSD: patch-ce,v 1.1 2001/10/15 22:46:04 skrll Exp $
|
|
|
|
--- klipper/Makefile.am.orig Wed Sep 5 00:16:17 2001
|
|
+++ klipper/Makefile.am
|
|
@@ -1,18 +1,19 @@
|
|
INCLUDES= $(all_includes)
|
|
|
|
bin_PROGRAMS = klipper
|
|
-lib_LTLIBRARIES = klipper.la
|
|
+lib_LTLIBRARIES = libklipper_main.la klipper.la
|
|
|
|
-CLEANFILES = dummy.cpp
|
|
-
|
|
-klipper_la_LIBADD = $(LIB_KDEUI) $(LIB_KSYCOCA)
|
|
-klipper_la_SOURCES = main.cpp toplevel.cpp urlgrabber.cpp configdialog.cpp
|
|
+libklipper_main_la_LIBADD = $(LIB_KDEUI) $(LIB_KSYCOCA)
|
|
+libklipper_main_la_SOURCES = main.cpp toplevel.cpp urlgrabber.cpp configdialog.cpp
|
|
+libklipper_main_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
|
|
+klipper_la_LIBADD = libklipper_main.la
|
|
+klipper_la_SOURCES = klipper_main.cpp
|
|
klipper_la_METASOURCES = AUTO
|
|
klipper_la_LDFLAGS = $(all_libraries) -module -avoid-version
|
|
|
|
-klipper_LDADD = klipper.la $(LIB_KSYCOCA)
|
|
-klipper_SOURCES = dummy.cpp
|
|
+klipper_LDADD = libklipper_main.la $(LIB_KSYCOCA)
|
|
+klipper_SOURCES = klipper_main.cpp
|
|
klipper_LDFLAGS = $(all_libraries) $(KDE_RPATH)
|
|
|
|
|
|
@@ -30,9 +31,6 @@
|
|
|
|
messages:
|
|
$(XGETTEXT) $(klipper_la_SOURCES) klipperbindings.cpp -o $(podir)/klipper.pot
|
|
-
|
|
-dummy.cpp:
|
|
- echo > dummy.cpp
|
|
|
|
# update script:
|
|
updatedir = $(kde_datadir)/kconf_update
|