pkgsrc/misc/stellarium/patches/patch-ab
adam 185408954a Changes 0.10.0:
* Global switch to Qt. Don't support SDL main application anymore.
* The whole StelApp class is managed by a QGraphicsScene, inside a
  QGraphicsView.
* Removed deprecated sources from the core of stellarium.
* Continued API cleaning and simplifications.
* Performed large refactorings to use portable Qt API.
* Re-organized the source files into sub-directories.
* Migrated config file parsing to a QSettings based implementation.
* Exposed some methods as slots so that they can be scripted in the future.
* Created the new Qt-based GUI button bars.
* Recoded from scratch the new QWidget based GUI rendered in the QGraphicsView
  using style sheets.
* Moved stars/planets halo rendering into SkyDrawer.
* Implemented dynamic eye adaptation for bright objects.
* Optimized atmosphere computation and others, speed can be increased up to
  a factor of 2.
* Implemented light pollution following the Bortle scale index.
* Improved and optimized stars rendering (updated colors, sizes and added
  large halo for very bright ones, use GL lists for drawing stars by bunch)
* Created a new SkyTile class supporting lazy dynamic multi-resolution images
  loading and display. Image trees can be stored as JSON files.
* Startup is much faster.
* Migrated the previous nebula textures to the new format.
* Added a LocationManager for managing observing locations and cleaned
  the code of observer.
* Changed key bindings, use F1.. F6 for opening dialogs.
* Tab completion on the search dialog.
* Added descriptions for the sky cultures and improved the ones for landscapes.
* Added a new mars landscape.
* Fixed many bugs.
2008-10-26 14:03:37 +00:00

13 lines
431 B
Text

$NetBSD: patch-ab,v 1.2 2008/10/26 14:03:37 adam Exp $
--- doc/CMakeLists.txt.orig 2008-10-26 14:40:24.000000000 +0100
+++ doc/CMakeLists.txt
@@ -20,7 +20,7 @@ ADD_CUSTOM_COMMAND(
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/stellarium.1
)
-INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/stellarium.1 DESTINATION share/man/man1)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/stellarium.1 DESTINATION man/man1)
ENDIF(UNIX AND NOT WIN32)