pkgsrc/devel/id-utils/patches/patch-af
seb 1034334372 - Fix build failure - exposed after lastest modification of
../../devel/gettext-lib/buildlink.mk - due to incorrect usage of @INTLIBS@ in
  Automake's prog_LDADD variable. Thanks Johnny Lam for hints and explanations!
- While here get ride off build dependencies on auto* tools and GNU make by
  using a new set of patches and AUTOMAKE_OVERRIDE.
  Note: new Makefile.am files and hence their patches were generated with
  automake-1.1b!
- sort PLIST and use same `install-info' arguments as those generated by
  `make print-PLIST'.
- Fix broken dependencies when USE_XEMACS is defined.
2001-11-03 09:59:35 +00:00

107 lines
3.1 KiB
Text

$NetBSD: patch-af,v 1.2 2001/11/03 09:59:36 seb Exp $
--- lisp/Makefile.in.orig Wed Aug 7 05:27:21 1996
+++ lisp/Makefile.in
@@ -4,6 +4,9 @@
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy, distribute and modify it.
+# Makefile.in's patch is produced after regen from Makefile.am with
+# automake-1.1b
+
SHELL = /bin/sh
@@ -39,12 +42,13 @@
transform = @program_transform_name@
EXTRA_DIST = id-utils.el elisp-comp
-elc_SCRIPTS = id-utils.elc
+elc_DATA = id-utils.elc
elcdir = @LISPDIR@
+eldir = @LISPDIR@
SUFFIXES = .el .elc
mkinstalldirs = $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h
-SCRIPTS = $(elc_SCRIPTS)
+DATA = $(elc_DATA)
DIST_COMMON = Makefile.am Makefile.in elisp-comp
@@ -67,20 +71,19 @@
Makefile: $(top_builddir)/config.status Makefile.in
cd $(top_builddir) && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= ./config.status
-install-elcSCRIPTS: $(elc_SCRIPTS)
+install-elcDATA: $(elc_DATA)
$(mkinstalldirs) $(elcdir)
- list="$(elc_SCRIPTS)"; for p in $$list; do \
- if test -f $$p; then \
- $(INSTALL_SCRIPT) $$p $(elcdir)/`echo $$p|sed '$(transform)'`; \
- else if test -f $(srcdir)/$$p; then \
- $(INSTALL_SCRIPT) $(srcdir)/$$p \
- $(elcdir)/`echo $$p|sed '$(transform)'`; \
- else :; fi; fi; \
+ list="$(elc_DATA)"; for p in $$list; do \
+ if test -f $(srcdir)/$$p; then \
+ $(INSTALL_DATA) $(srcdir)/$$p $(elcdir)/$$p; \
+ else if test -f $$p; then \
+ $(INSTALL_DATA) $$p $(elcdir)/$$p; \
+ fi; fi; \
done
-uninstall-elcSCRIPTS:
- list="$(elc_SCRIPTS)"; for p in $$list; do \
- rm -f $(elcdir)/`echo $$p|sed '$(transform)'`; \
+uninstall-elcDATA:
+ list="$(elc_DATA)"; for p in $$list; do \
+ rm -f $(elcdir)/$$p; \
done
tags: TAGS
TAGS:
@@ -105,14 +108,15 @@
install-exec:
-install-data: install-elcSCRIPTS
+install-data: install-elcDATA
+ $(MAKE) install-data-hook
install: install-exec install-data all
@:
-uninstall: uninstall-elcSCRIPTS
+uninstall: uninstall-elcDATA
-all: $(SCRIPTS) Makefile
+all: $(DATA) Makefile
install-strip:
$(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
@@ -144,15 +148,22 @@
@echo "This command is intended for maintainers to use;"
@echo "it deletes files that may require special tools to rebuild."
-.PHONY: default uninstall-elcSCRIPTS install-elcSCRIPTS tags distdir \
-info dvi check installcheck install-exec install-data install uninstall \
-all installdirs mostlyclean-generic distclean-generic clean-generic \
+.PHONY: default uninstall-elcDATA install-elcDATA tags distdir info dvi \
+check installcheck install-exec install-data install uninstall all \
+installdirs mostlyclean-generic distclean-generic clean-generic \
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
+.SUFFIXES: .el .elc
.el.elc:
@echo "WARNING: Warnings can be ignored. :-)"
- $(SHELL) $(srcdir)/elisp-comp $<
+ $(BSD_SETENV) EMACS=@EMACS@ $(SHELL) $(srcdir)/elisp-comp $<
+
+install-data-hook:
+ if test -f id-utils.elc; then \
+ $(mkinstalldirs) $(eldir); \
+ $(INSTALL_DATA) $(srcdir)/id-utils.el $(eldir)/id-utils.el; \
+ fi
.SUFFIXES:
.SUFFIXES: .el .elc