pkgsrc/devel/id-utils/patches/patch-ah
seb 1034334372 - Fix build failure - exposed after lastest modification of
../../devel/gettext-lib/buildlink.mk - due to incorrect usage of @INTLIBS@ in
  Automake's prog_LDADD variable. Thanks Johnny Lam for hints and explanations!
- While here get ride off build dependencies on auto* tools and GNU make by
  using a new set of patches and AUTOMAKE_OVERRIDE.
  Note: new Makefile.am files and hence their patches were generated with
  automake-1.1b!
- sort PLIST and use same `install-info' arguments as those generated by
  `make print-PLIST'.
- Fix broken dependencies when USE_XEMACS is defined.
2001-11-03 09:59:35 +00:00

21 lines
643 B
Text

$NetBSD: patch-ah,v 1.2 2001/11/03 09:59:36 seb Exp $
--- src/Makefile.am.orig Sun Jun 9 02:22:34 1996
+++ src/Makefile.am
@@ -1,5 +1,8 @@
## Process this file with automake to create Makefile.in
+# Makefile.in's patch is produced after regen from Makefile.am with
+# `automake-1.1b --include-deps,' then it is hand-trimmed
+
AUTOMAKE_OPTIONS = ansi2knr
bin_PROGRAMS = mkid lid fid fnid xtokid
@@ -16,5 +19,6 @@
-I.. -I$(top_srcdir)
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
LDADD = @INTLLIBS@ ../libidu/libidu.a ../lib/libsys.a
+DEPLIBS = ../libidu/libidu.a ../lib/libsys.a
-$(PROGRAMS): $(LDADD)
+$(PROGRAMS): $(DEPLIBS)