29542b0dfb
1.79.0: * Clean up auto-generation of files; removed 'register' * Some fixes for issues identified by fuzzer * New source files: checkerboard.c * New programs: replacebytes.c, webpanimio_reg.c, partifytest.c, rectangle_reg.c, lowsat_reg.c, rotate_it.c, scale_it.c, dewarp_it.c, pdfio1_reg.c, pdfio2_reg.c, checkerboard_reg.c, underlinetest.c. * Convert to standard reg test: heap_reg.c, pixa1_reg.c, smallpix_reg.c * Improve data checking when reading image file headers (pnm, png, jpeg, tiff) * Fix some bugs in pnm reading * Fix inconsistencies with the encoding type flags in pdf writing * Allow tiff to write images with colormaps * Fix errors in PS code; made some functions static * Add code for animated webp (requires webp mux and demux libraries) * Add "partify" application for separating parts in a musical score * Enable tif read/write of gray+alpha and rgba; filter out tiff pixels that are not uint and compression by tile * Apply consistent formatting of static const variables * Add programs for scaling, rotation and deskew, named dewkew_it, rotate_it and scale_it, for useful operations on arbitrary images. * Convert pdfiotest program to two regression tests: pdfio1_reg and pdfio2_reg. * Remove all use of strncat; use stringCat(). * New functions from removing outliers in sequences of boxes. * Generalize pixAverageInRect(): mask, region and range filters, and subsampling. New pixAverageInRectRGB(). * Fix int overflow bug in pixMedianCut(); required new heap accessor. * New pixMultiplyGray() allows pix to be multiplied by an array (or another pix) * Better routines for counting color. * Lossless conversion for RGB to cmap with not more than 256 colors. * New histo based global thresholding: pixThresholdByHisto(). * Allow most reg tests to run even if external libraries are not available. * New one-line gplot functions that return a pix. * New application to find where corners meet in a checkerboard. * Add utility functions for painting through mask in cmap pix, creating a hit-miss sela from a color pix, equality of two pta. * Proper handling of 1 bpp colormap tiffs: remove when reading, preserve when writing. * Deprecate three pixSaveTile*() functions; removed all calls to these from the library and progs. * Include auto_config.h explicitly in all src and prog files. * Improve input data checking for bmp files.
14 lines
377 B
Text
14 lines
377 B
Text
$NetBSD: patch-src_Makefile.in,v 1.1 2020/01/02 12:55:07 adam Exp $
|
|
|
|
Do not create libleptonica.* links.
|
|
|
|
--- src/Makefile.in.orig 2019-12-31 22:17:02.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -1196,7 +1196,6 @@ info-am:
|
|
|
|
install-data-am: install-pkgincludeHEADERS
|
|
@$(NORMAL_INSTALL)
|
|
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
|
|
install-dvi: install-dvi-am
|
|
|
|
install-dvi-am:
|