397d50de8f
This update is based on patches provided by Ron Roskens (roskens at elfin dot net) in PR pkg/20271 and his posts to tech-pkg@. Furthermore, this update fixes PR pkg/20109 by Bill Sommerfeld. Changes since our last version include: * src/register/ledger-core/split-register-control.c If we're expanded, ignore TRANS cursor classes. This prevents a bug where the exchange-rate dialog is realized when there really is nothing to do (because we're in an expanded transaction). * src/register/ledger-core/split-register-model.c Don't PERR() if we have no account -- this prevents annoying messages when handling multi-currency txns in the GL. Note: all GL txns are displayed in the locale currency (if possible). * src/register/ledger-core/split-register.c AUTO_LEDGER and JOURNAL register types _ARE_ expanded -- return TRUE, not FALSE. * src/report/standard-report/advanced-portfolio.scm: add extra arguments to prevent scheme crash. * src/gnome/glade/sched-xact.glade: Need to start the Editor dialog as non-visible so the ledger get's sized properly * src/gnome/dialog-scheduledxaction.c: resize the cal after the dialog is shown, so it get's sized properly. * src/register/register-gnome/gnucash-style.c: temporary fix to prevent 105346, until a real fix can be created. There is still a visual artifact leftover, but at least it doesn't crash. * src/scm/tip-list.scm: remove the tip that says that this is a development version. (Thanks, pogma) * src/scm/command-line.scm: remove the "development version" string when running "gnucash --version" * src/import-export/import-backend.c: Add heuristic for duplicate matching by check number. * doc/README.OFX: Update * src/engine/gnc-lot-p.h: some strange platforms assume "char" is 0..255 instead of -128..127. Force a "signed char" to make sure we get the latter interpretation. * src/app-utils/gnc-ui-utils.c: Don't round unless force_fit is true. Fixes Debian Bug #179802. * src/bin/overrides/gnucash-build-env.in: add business-utils * src/business/business-utils/Makefile.am: make scm-links so you can run gnucash from within the build tree * po/it.po: Updated Italian translation by Lorenzo Cappelletti <L.Cappelletti@mail.com>. * src/import-export/qif-import/qif-file.scm: mark "splits" as negative to make sure the numbers are reflected appropriately. * src/import-export/qif-import/qif-objects.scm: add a neg? value to a qif-split; use this when converting the split-amount. Fixes bug #105179 * src/calculation/Makefile.am: need to add GUILE_INCS * src/engine/Makefile.am: add ${INTLLIBS} for gettext() et al on platforms that don't have it in libc * src/backend/file/io-gncbin-r.c: don't need to define functions that are never used, so move the #ifdef around. Fixes # 105124 * src/import-export/qif-import/qif-file.scm: fix a wrong-number-of-arguments fatal crash when trying to reparse dates. * src/scm/main.scm: turn off devel version message
13 lines
396 B
Text
13 lines
396 B
Text
$NetBSD: patch-bg,v 1.1 2003/02/27 04:08:25 jschauma Exp $
|
|
|
|
--- doc/examples/Makefile.in.orig Tue Feb 25 22:00:08 2003
|
|
+++ doc/examples/Makefile.in Tue Feb 25 22:02:40 2003
|
|
@@ -228,7 +228,7 @@
|
|
enable_html_docs = @enable_html_docs@
|
|
enable_latex_docs = @enable_latex_docs@
|
|
|
|
-docdir = ${GNC_DOC_INSTALL_DIR}/examples
|
|
+docdir = ${datadir}/examples/gnucash
|
|
|
|
doc_DATA = \
|
|
Money95bank_fr.qif \
|