pkgsrc/sysutils/grub2/patches/patch-stpcpy-2-gen.diff
gsutre d4ff70ea49 Import grub2-2.00 as sysutils/grub2.
This is GRUB 2, the second version of the GRand Unified Bootloader.
GRUB 2 is rewritten from scratch to make GNU GRUB cleaner, safer, more
robust, more powerful, and more portable.
2012-07-29 21:44:13 +00:00

177 lines
7.6 KiB
Diff

$NetBSD: patch-stpcpy-2-gen.diff,v 1.1 2012/07/29 21:44:13 gsutre Exp $
Add gnulib's stpcpy. Generated files only.
diff -Naurp grub-2.00/Makefile.in grub-2.00.stpcpy/Makefile.in
--- Makefile.in 2012-06-26 14:12:41.000000000 +0200
+++ Makefile.in 2012-07-28 16:02:25.351302756 +0200
@@ -6070,7 +6070,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/0
$(top_srcdir)/m4/ssize_t.m4 $(top_srcdir)/m4/stdbool.m4 \
$(top_srcdir)/m4/stddef_h.m4 $(top_srcdir)/m4/stdint.m4 \
$(top_srcdir)/m4/stdint_h.m4 $(top_srcdir)/m4/stdio_h.m4 \
- $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/strcase.m4 \
+ $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
$(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strerror.m4 \
$(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
$(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \
diff -Naurp grub-2.00/aclocal.m4 grub-2.00.stpcpy/aclocal.m4
--- aclocal.m4 2012-06-26 13:59:13.000000000 +0200
+++ aclocal.m4 2012-07-28 15:57:51.202749270 +0200
@@ -1088,6 +1088,7 @@ m4_include([m4/stdint.m4])
m4_include([m4/stdint_h.m4])
m4_include([m4/stdio_h.m4])
m4_include([m4/stdlib_h.m4])
+m4_include([m4/stpcpy.m4])
m4_include([m4/strcase.m4])
m4_include([m4/strchrnul.m4])
m4_include([m4/strerror.m4])
diff -Naurp grub-2.00/configure grub-2.00.stpcpy/configure
--- configure 2012-06-26 13:59:16.000000000 +0200
+++ configure 2012-07-28 15:57:56.658680680 +0200
@@ -6778,6 +6778,7 @@ $as_echo "$ac_cv_safe_to_define___extens
# Code from module stdint:
# Code from module stdio:
# Code from module stdlib:
+ # Code from module stpcpy:
# Code from module strcase:
# Code from module strchrnul:
# Code from module streq:
@@ -17952,6 +17953,55 @@ fi
done
+ # Code from module stpcpy:
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+ for ac_func in stpcpy
+do :
+ ac_fn_c_check_func "$LINENO" "stpcpy" "ac_cv_func_stpcpy"
+if test "x$ac_cv_func_stpcpy" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_STPCPY 1
+_ACEOF
+
+else
+
+ gl_LIBOBJS="$gl_LIBOBJS $ac_func.$ac_objext"
+
+fi
+done
+
+
+ if test $ac_cv_func_stpcpy = no; then
+ HAVE_STPCPY=0
+
+ :
+
+ fi
+
+
+
+
+ GNULIB_STPCPY=1
+
+
+
+$as_echo "#define GNULIB_TEST_STPCPY 1" >>confdefs.h
+
+
+
# Code from module strcase:
diff -Naurp grub-2.00/docs/Makefile.in grub-2.00.stpcpy/docs/Makefile.in
--- docs/Makefile.in 2012-06-26 13:59:17.000000000 +0200
+++ docs/Makefile.in 2012-07-28 16:02:37.319152299 +0200
@@ -89,7 +89,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/0
$(top_srcdir)/m4/ssize_t.m4 $(top_srcdir)/m4/stdbool.m4 \
$(top_srcdir)/m4/stddef_h.m4 $(top_srcdir)/m4/stdint.m4 \
$(top_srcdir)/m4/stdint_h.m4 $(top_srcdir)/m4/stdio_h.m4 \
- $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/strcase.m4 \
+ $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
$(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strerror.m4 \
$(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
$(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \
diff -Naurp grub-2.00/grub-core/Makefile.in grub-2.00.stpcpy/grub-core/Makefile.in
--- grub-core/Makefile.in 2012-06-26 14:12:27.000000000 +0200
+++ grub-core/Makefile.in 2012-07-28 16:02:31.483225667 +0200
@@ -23878,7 +23878,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/0
$(top_srcdir)/m4/ssize_t.m4 $(top_srcdir)/m4/stdbool.m4 \
$(top_srcdir)/m4/stddef_h.m4 $(top_srcdir)/m4/stdint.m4 \
$(top_srcdir)/m4/stdint_h.m4 $(top_srcdir)/m4/stdio_h.m4 \
- $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/strcase.m4 \
+ $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
$(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strerror.m4 \
$(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
$(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \
diff -Naurp grub-2.00/grub-core/gnulib/Makefile.in grub-2.00.stpcpy/grub-core/gnulib/Makefile.in
--- grub-core/gnulib/Makefile.in 2012-06-26 14:00:29.000000000 +0200
+++ grub-core/gnulib/Makefile.in 2012-07-28 16:05:07.073269635 +0200
@@ -24,7 +24,7 @@
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=grub-core/gnulib --m4-base=m4 --doc-base=doc --tests-base=tests --aux-dir=build-aux --no-libtool --macro-prefix=gl --no-vc-files argp error fnmatch getdelim getline gettext progname regex stpcpy
@@ -101,7 +101,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/0
$(top_srcdir)/m4/ssize_t.m4 $(top_srcdir)/m4/stdbool.m4 \
$(top_srcdir)/m4/stddef_h.m4 $(top_srcdir)/m4/stdint.m4 \
$(top_srcdir)/m4/stdint_h.m4 $(top_srcdir)/m4/stdio_h.m4 \
- $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/strcase.m4 \
+ $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
$(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strerror.m4 \
$(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
$(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \
@@ -843,7 +843,7 @@ EXTRA_DIST = alloca.c alloca.in.h \
rawmemchr.valgrind realloc.c regcomp.c regex.c regex.h \
regex_internal.c regex_internal.h regexec.c sleep.c \
stdbool.in.h stddef.in.h stdint.in.h stdio-write.c stdio.in.h \
- stdlib.in.h strcasecmp.c strncasecmp.c strchrnul.c \
+ stdlib.in.h stpcpy.c strcasecmp.c strncasecmp.c strchrnul.c \
strchrnul.valgrind streq.h strerror.c string.in.h strings.in.h \
strndup.c strnlen.c sys_wait.in.h sysexits.in.h unistd.in.h \
asnprintf.c float+.h printf-args.c printf-args.h \
@@ -904,7 +904,7 @@ EXTRA_libgnu_a_SOURCES = alloca.c btowc.
mbrtowc.c mbsinit.c mbsrtowcs-state.c mbsrtowcs.c memchr.c \
mempcpy.c nl_langinfo.c rawmemchr.c realloc.c regcomp.c \
regex.c regex_internal.c regexec.c sleep.c stdio-write.c \
- strcasecmp.c strncasecmp.c strchrnul.c strerror.c strndup.c \
+ stpcpy.c strcasecmp.c strncasecmp.c strchrnul.c strerror.c strndup.c \
strnlen.c asnprintf.c printf-args.c printf-parse.c \
vasnprintf.c vsnprintf.c wcrtomb.c
ARG_NONNULL_H = arg-nonnull.h
@@ -1013,6 +1013,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/regexec.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sleep.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/stdio-write.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/stpcpy.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/strcasecmp.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/strchrnul.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/strerror.Po@am__quote@
diff -Naurp grub-2.00/util/bash-completion.d/Makefile.in grub-2.00.stpcpy/util/bash-completion.d/Makefile.in
--- util/bash-completion.d/Makefile.in 2012-06-26 14:00:29.000000000 +0200
+++ util/bash-completion.d/Makefile.in 2012-07-28 16:02:28.407264338 +0200
@@ -87,7 +87,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/0
$(top_srcdir)/m4/ssize_t.m4 $(top_srcdir)/m4/stdbool.m4 \
$(top_srcdir)/m4/stddef_h.m4 $(top_srcdir)/m4/stdint.m4 \
$(top_srcdir)/m4/stdint_h.m4 $(top_srcdir)/m4/stdio_h.m4 \
- $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/strcase.m4 \
+ $(top_srcdir)/m4/stdlib_h.m4 $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
$(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strerror.m4 \
$(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
$(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \