pkgsrc/games/powermanga/patches/patch-ad
wiz 0a335da3e6 Update to 0.90:
2007-09-02
Powermanga 0.90
- the sounds were updated to replace non-free sounds
- joystick support was added
- scale2x, scale3x, and scale4x effects were added
- the order text was changed to support both plain text and keystrokes file
- the source code files were renamed
- the code was considerably cleaned up and rewritten
- comments and variables were translated to the English language
- all C++ code was removed and the remaining code was made to conform with C99
- the license was changed to the GPLv3
- resources files were renamed
- volume control was added
- GP2X and PSP patches were merged
- the high-score file format was changed

2006-03-27
Powermanga 0.80
- compile with GCC 4.0.3
- fix palette conversion in 16 bits RGB color mode (non-IA32 architecture)
- add config file
- add french language support
- various bugs fixes
- compile, run, and test the project on AMD64 (Ubuntu Dapper Drake)
- compile, run, and test the project on Win32 (Patrice Duhamel)
- upload the source code on CVS (http://sourceforge.net/projects/powermanga/)
2009-09-02 11:38:01 +00:00

33 lines
1.4 KiB
Text

$NetBSD: patch-ad,v 1.3 2009/09/02 11:38:01 wiz Exp $
--- src/Makefile.in.orig 2007-09-04 08:41:04.000000000 +0000
+++ src/Makefile.in
@@ -220,8 +220,8 @@ target_alias = @target_alias@
target_cpu = @target_cpu@
target_os = @target_os@
target_vendor = @target_vendor@
-gamesdir = $(prefix)/games
-scoredir = /var/games
+gamesdir = $(prefix)/bin
+scoredir = $(localstatedir)/games
score = powermanga.hi
powermanga_SOURCES = $(SOURCES_MAIN) $(SOURCES_EXTRA)
#powermanga_CXXFLAGS = -DPREFIX=\"$(prefix)\" -DSCOREFILE=\"$(scoredir)/$(score)\" @XLIB_CFLAGS@ @SDL_CFLAGS@
@@ -1247,13 +1247,10 @@ uninstall-am: uninstall-gamesPROGRAMS un
install-data-hook:
- -chown root:games "$(DESTDIR)/$(gamesdir)/powermanga"
- -chmod 2755 "$(DESTDIR)/$(gamesdir)/powermanga"
- $(INSTALL) -d $(DESTDIR)/$(scoredir)
- -for suffix in "-easy" "" "-hard"; do \
- touch "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
- chown root:games "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
- chmod 644 "$(DESTDIR)/$(scoredir)/$(score)$$suffix"; \
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)/$(scoredir)
+ @for suffix in "-easy" "" "-hard"; do \
+ $(TOUCH) "$(WRKSRC)/$(score)$$suffix" && \
+ $(BSD_INSTALL_GAME_DATA) "$(WRKSRC)/$(score)$$suffix" $(DESTDIR)/$(scoredir)/; \
done
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.