pkgsrc/misc/screen/patches/patch-ak
kim cd19f8d470 Upgrade misc/screen to version 4.6.1
Version 4.6.1 (10/07/2017):
  * Fixes:
    - problems with starting session in some cases
    - parallel make install
    - segfault when querying info on nonUTF locale

Version 4.6.0 (28/06/2017):
  * Update Unicode wide tables to 9.0
  * Support more serial speeds
  * Improved namespaces support
  * Migrate from fifos to sockets
  * Start viewing scrollback at first line of output
2017-07-18 23:02:18 +00:00

38 lines
1 KiB
Text

$NetBSD: patch-ak,v 1.9 2017/07/18 23:02:18 kim Exp $
Patch configure after configure.ac (see patch-aj).
Include curses header when testing tgetent in order to prevent
crash on 64-bit architectures.
Detect getutent correctly on NetBSD with utmpx.
--- configure.orig 2017-07-10 19:26:25.000000000 +0000
+++ configure 2017-07-18 22:50:46.000000000 +0000
@@ -4985,6 +4985,8 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
+#include <curses.h>
+
main()
{
exit(strcmp(tgoto("%p1%d", 0, 1), "1") ? 0 : 1);
@@ -5381,9 +5383,16 @@
#include <time.h> /* to get time_t on SCO */
#include <sys/types.h>
-#if defined(SVR4) && !defined(DGUX)
+#include <sys/param.h>
+#if (defined(SVR4) && !defined(DGUX)) \
+ || (defined(__NetBSD_Version__) && (__NetBSD_Version__ >= 106050000)) \
+ || (defined(__DragonFly__) && (__DragonFly_version >= 200902))
#include <utmpx.h>
#define utmp utmpx
+# if defined(__NetBSD__) || defined(__DragonFly__)
+# define pututline pututxline
+# define getutent getutxent
+# endif
#else
#include <utmp.h>
#endif