pkgsrc/audio/audacity/patches/patch-ar
jlam 7127103646 Update audio/audacity to 1.0.0.2. Pkgsrc changes from version 0.96 include:
* Use the id3lib distributed with the audacity sources instead of
	  audio/id3lib (this seems to fix audacity coredumps when exporting
	  to MP3 after editting ID3 tags).
	* Install the documentation and license file.

Changes from version 0.96 include:

	* Bug fixes
	* New effects: invert, reverse, noise removal
	* Ogg Vorbis import/export support.
	* Added "Save Changes" dialog.
	* Added tooltips.
	* Use libmad instead of libmpeg3 if not using xaudio.

XXX OSS audio playback doesn't work on NetBSD with audio/oss.  The process
XXX hangs in "sndint" state according to top(1).
2002-10-04 08:59:34 +00:00

84 lines
2.4 KiB
Text

$NetBSD: patch-ar,v 1.1 2002/10/04 08:59:38 jlam Exp $
--- configure.in.orig Wed Jun 5 00:51:19 2002
+++ configure.in
@@ -34,6 +34,16 @@ AC_ARG_WITH(oss,
[use Open Sound System (OSS) for Audio I/O [default=yes]])],
use_oss=$withval,
use_oss="default")
+AC_ARG_WITH(dev-dsp,
+ [AC_HELP_STRING([--with-dev-dsp],
+ [the path to the audio device [default="/dev/dsp"]])],
+ DEV_DSP=$withval,
+ DEV_DSP="/dev/dsp")
+AC_ARG_WITH(helpdir,
+ [AC_HELP_STRING([--with-helpdir],
+ [the path to the audacity help file [default=empty]])],
+ HELPDIR=$withval,
+ HELPDIR="$prefix/share/doc/audacity")
AC_ARG_WITH(arts-soundserver,
[AC_HELP_STRING([--with-arts-soundserver],
[use the KDE/aRts soundserver instead of OSS [default=no]])],
@@ -65,6 +75,9 @@ AC_ARG_WITH(help,
use_help=$withval,
use_help="yes")
+AC_SUBST(DEV_DSP)
+AC_SUBST(HELPDIR)
+
dnl check to make sure that all the user's options are valid
AC_CANONICAL_HOST
host_cpu=`echo "$host_cpu" | sed "s/i.86/i386/"`
@@ -161,12 +174,26 @@ if [[ $use_vorbis = "yes" ]] ; then
fi
if [[ $use_id3lib = "yes" ]] ; then
+
+ dnl check for both headers and libraries
+
+ AC_CHECK_LIB(z, compress)
+ AC_CHECK_LIB(id3-3.8, main, id3lib_found="-lid3-3.8",
+ AC_CHECK_LIB(id3, main, id3lib_found="-lid3",
+ id3lib_found=no))
+
+ AC_CHECK_HEADER(id3.h, id3inc_found=yes, id3inc_found=no)
+
+ if [[ $id3lib_found = "no" ]] || [[ $id3inc_found = "no" ]] ; then
EXTRAOBJS="$EXTRAOBJS id3lib/src/.libs/libid3.a"
MAKEALL="$MAKEALL id3lib/src/.libs/libid3.a"
CFLAGS="$CFLAGS -Iid3lib/include"
+ elif [[ $id3lib_found != "no" ]] ; then
+ LIBS="$LIBS $id3lib_found"
+ fi
AC_DEFINE(USE_ID3LIB, 1,
- [Define if id3lib is present])
+ [Define if id3lib is present])
fi
if [[ $use_help = "yes" ]] ; then
@@ -174,6 +201,24 @@ if [[ $use_help = "yes" ]] ; then
fi
if [[ $use_oss = "yes" ]] ; then
+ AC_CHECK_HEADER(sys/soundcard.h, [
+ CFLAGS="$CFLAGS -DHAVE_SYS_SOUNDCARD_H=1"
+ AC_EGREP_CPP(yes, [
+#include <sys/soundcard.h>
+#if defined(OPEN_SOUND_SYSTEM) || defined(UNIX_SOUND_SYSTEM)
+yes
+#endif
+ ],, [
+ AC_CHECK_FUNC(_oss_ioctl,,
+ [AC_CHECK_LIB(ossaudio,_oss_ioctl)])
+ ])
+ ], [
+ AC_CHECK_HEADER(soundcard.h, [
+ CFLAGS="$CFLAGS -DHAVE_SOUNDCARD_H=1"
+ AC_CHECK_FUNC(_oss_ioctl,,
+ [AC_CHECK_LIB(ossaudio,_oss_ioctl)])])
+ ])
+
EXTRAOBJS="$EXTRAOBJS \$(OBJDIR)/snd/audiooss.c.o"
AC_DEFINE(USE_OSS, 1,