pkgsrc/x11/c++-gtk-utils/patches/patch-c++-gtk-utils_Makefile.in
ryoon bbb1abd212 Import c++-gtk-utils-2.2.7 as x11/c++-gtk-utils.
c++-gtk-utils is a lightweight library containing a number of
classes and functions for programming GTK+ programs using C++ in
POSIX (unix-like) environments, where the user does not want to
use a full-on wrapper such as gtkmm or wxWidgets, or is concerned
about exception safety or thread safety of the wrapper and their
documentation. It is parallel installable for both GTK+2 and GTK+3.
There is also an option to install a subset of the library with
only glib/gobject/gio support, without GTK+.
2014-07-19 06:39:31 +00:00

15 lines
613 B
Text

$NetBSD: patch-c++-gtk-utils_Makefile.in,v 1.1 2014/07/19 06:39:31 ryoon Exp $
* Fix not found errors of essential functions
--- c++-gtk-utils/Makefile.in.orig 2014-05-30 22:41:36.000000000 +0000
+++ c++-gtk-utils/Makefile.in
@@ -411,7 +411,7 @@ pkginclude_HEADERS = fdstream.h fdstream
task_manager.h task_manager.tpp \
parallel.h cgu_config.h
-AM_CXXFLAGS = -D_XOPEN_SOURCE=600 @PTHREAD_FLAG_CXX@ @GTK_UNIX_PRINT_CFLAGS@ \
+AM_CXXFLAGS = @PTHREAD_FLAG_CXX@ @GTK_UNIX_PRINT_CFLAGS@ \
@GTK_CFLAGS@ @GIO_CFLAGS@ @DBUS_GLIB_CFLAGS@ @GTHREAD_CFLAGS@ \
@GLIB_CFLAGS@ -I..