0f1b30d68f
Based on a patch provided by Michal Pasternak in PR 23830.
25 lines
778 B
Text
25 lines
778 B
Text
$NetBSD: patch-ab,v 1.1 2004/01/17 13:16:06 recht Exp $
|
|
|
|
--- setup.py.orig 2004-01-17 14:10:14.000000000 +0100
|
|
+++ setup.py 2004-01-17 14:11:27.000000000 +0100
|
|
@@ -82,7 +82,7 @@
|
|
|
|
def main():
|
|
# Set this to 1 if you need to use your own settings
|
|
- USE_CUSTOM = 0
|
|
+ USE_CUSTOM = 1
|
|
|
|
# Default settings, may be overriden for specific platforms
|
|
pypgsql_rt_dirs = None
|
|
@@ -98,8 +98,9 @@
|
|
"port/strtok.c"]
|
|
|
|
if USE_CUSTOM:
|
|
- include_dirs = YOUR_LIST_HERE
|
|
- library_dirs = YOUR_LIST_HERE
|
|
+ LOCALBASE = os.environ.get('LOCALBASE', '/usr/pkg')
|
|
+ include_dirs = ['%s/include/pgsql' % LOCALBASE]
|
|
+ library_dirs = ['%s/lib' % LOCALBASE]
|
|
elif sys.platform == "linux2":
|
|
include_dirs = ["/usr/include", "/usr/include/postgresql",
|
|
"/usr/include/pgsql"]
|