19 lines
595 B
Text
19 lines
595 B
Text
$NetBSD: patch-ab,v 1.2 2014/05/01 10:28:30 obache Exp $
|
|
|
|
* Use posix_memalign(3) if possible.
|
|
https://github.com/tegaki/tegaki/pull/8
|
|
|
|
--- setup.py.orig 2010-02-27 04:51:50.000000000 +0000
|
|
+++ setup.py
|
|
@@ -25,8 +25,10 @@ def pkg_config(package, option):
|
|
sub.wait()
|
|
return [a[2:] for a in args]
|
|
|
|
-if platform.system() in ["Darwin", "Windows"]:
|
|
+if platform.system() in ["Darwin", "OpenBSD", "Windows"]:
|
|
macros = []
|
|
+elif platform.system() in ["NetBSD", "FreeBSD", "DragonFly"]:
|
|
+ macros = [("HAVE_POSIX_MEMALIGN", None)]
|
|
else:
|
|
macros = [("HAVE_MEMALIGN", None)]
|
|
|