a7c3fc28ed
What's new from release notes - Multiple homepages - Sidebar remembers its state across sessions - Download fixes - History improvements - Accessibility improvements - Size and memory reduction - Performance improvements - Stability improvements - Better Windows appearance - Many more new themes - Too many fixes to list See below for detail. http://www.mozilla.org/projects/phoenix/phoenix-release-notes.html
37 lines
862 B
Text
37 lines
862 B
Text
$NetBSD: patch-ab,v 1.2 2002/12/10 16:02:40 taya Exp $
|
|
|
|
--- ../Orig/mozilla/configure.in Mon Dec 9 12:18:31 2002
|
|
+++ ./configure.in Tue Dec 10 08:32:45 2002
|
|
@@ -1137,6 +1137,13 @@
|
|
if test "$LIBRUNPATH"; then
|
|
DSO_LDOPTS="-Wl,-R$LIBRUNPATH $DSO_LDOPTS"
|
|
fi
|
|
+
|
|
+ case "${target_cpu}" in
|
|
+ alpha*)
|
|
+ CFLAGS="$CFLAGS -mieee"
|
|
+ CXXFLAGS="$CXXFLAGS -mieee"
|
|
+ ;;
|
|
+ esac
|
|
;;
|
|
|
|
*-nto*)
|
|
@@ -1494,7 +1501,7 @@
|
|
[siginfo_t* info;],
|
|
[ac_cv_siginfo_t=true],
|
|
[ac_cv_siginfo_t=false])])
|
|
-if test "$ac_cv_siginfo_t" = true ; then
|
|
+if test "$OS_TARGET" != "NetBSD" -a "$ac_cv_siginfo_t" = true ; then
|
|
AC_DEFINE(HAVE_SIGINFO_T)
|
|
AC_MSG_RESULT(yes)
|
|
else
|
|
@@ -2028,9 +2035,6 @@
|
|
CXXFLAGS="$CXXFLAGS -mt"
|
|
fi
|
|
;;
|
|
- *-*-netbsd*)
|
|
- USE_PTHREADS=
|
|
- _PTHREAD_LDFLAGS=
|
|
esac
|
|
fi
|
|
|