pkgsrc/converters/utf8proc/patches/patch-CMakeLists.txt
minskim 63315c45b4 converters/utf8proc: Update to 2.2.0
Changes:
- Unicode 11 support
- utf8proc_NFKC_Casefold convenience function for NFKC_Casefold
  normalization
- UTF8PROC_STRIPNA option to strip unassigned codepoints.
- Support building static libraries on Windows (callers need to
  #define UTF8PROC_STATIC)
- cmake fix to avoid defining UTF8PROC_EXPORTS globally
- toupper of U+00df now yields U+1E9E, similar to musl; case-folding
  still yields the standard "ss" mapping.
- utf8proc_charwidth now returns 1 for U+00AD (soft hyphen) and for
  unassigned/PUA codepoints.
2018-08-17 15:22:37 +00:00

16 lines
370 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.2 2018/08/17 15:22:37 minskim Exp $
Allow in-tree builds.
--- CMakeLists.txt.orig 2018-07-24 17:35:48.000000000 +0000
+++ CMakeLists.txt
@@ -1,9 +1,5 @@
cmake_minimum_required (VERSION 2.8.12)
-include (utils.cmake)
-
-disallow_intree_builds()
-
project (utf8proc C)
# This is the ABI version number, which may differ from the