pkgsrc/textproc/ispell-base/patches/patch-ab
seb 66111c6d15 Introduce new framework for handling info files generation and installation.
Summary of changes:
- removal of USE_GTEXINFO
- addition of mk/texinfo.mk
- inclusion of this file in package Makefiles requiring it
- `install-info' substituted by `${INSTALL_INFO}' in PLISTs
- tuning of mk/bsd.pkg.mk:
    removal of USE_GTEXINFO
    INSTALL_INFO added to PLIST_SUBST
    `${INSTALL_INFO}' replace `install-info' in target rules
    print-PLIST target now generate `${INSTALL_INFO}' instead of `install-info'
- a couple of new patch files added for a handful of packages
- setting of the TEXINFO_OVERRIDE "switch" in packages Makefiles requiring it
- devel/cssc marked requiring texinfo 4.0
- a couple of packages Makefiles were tuned with respect of INFO_FILES and
  makeinfo command usage

See -newly added by this commit- section 10.24 of Packages.txt for
further information.
2002-02-18 15:14:00 +00:00

69 lines
1.8 KiB
Text

$NetBSD: patch-ab,v 1.2 2002/02/18 15:14:43 seb Exp $
--- Makefile.orig Thu Oct 12 20:04:06 1995
+++ Makefile
@@ -240,31 +240,15 @@
set $(SHELLDEBUG); \
if [ -d $$TEXINFODIR -a -r ispell.info ]; then \
set -ex; \
- rm -f $$TEXINFODIR/ispell; \
- $$INSTALL ispell.info $$TEXINFODIR/ispell; \
- chmod 644 $$TEXINFODIR/ispell; \
+ rm -f $$TEXINFODIR/ispell.info; \
+ $$INSTALL ispell.info $$TEXINFODIR/ispell.info; \
+ chmod 644 $$TEXINFODIR/ispell.info; \
else \
: ; \
fi
@set +e; \
. ./config.sh; \
set $(SHELLDEBUG); \
- if [ -d $$ELISPDIR ]; then \
- set -ex; \
- rm -f $$ELISPDIR/ispell.el; \
- $$INSTALL ispell.el $$ELISPDIR; \
- if sh iwhich $$EMACS >/dev/null; then \
- echo '(byte-compile-file "'"$$ELISPDIR/ispell.el"'")' \
- > /tmp/emi$$$$; \
- $$EMACS -batch -l /tmp/emi$$$$; \
- rm -f /tmp/emi$$$$; \
- chmod 644 $$ELISPDIR/ispell.el $$ELISPDIR/ispell.elc; \
- else \
- chmod 644 $$ELISPDIR/ispell.el; \
- fi; \
- else \
- : ; \
- fi
install-dictbuild:
@. ./config.sh; \
@@ -323,8 +307,8 @@
. ./config.sh; \
set $(SHELLDEBUG); \
if [ -d $$TEXINFODIR ]; then \
- if sh iwhich makeinfo >/dev/null \
- && makeinfo ispell.texinfo 2>/dev/null; then \
+ if true >/dev/null \
+ && $(MAKEINFO) --no-split --force ispell.texinfo 2>/dev/null; true; then \
:; \
elif sh iwhich $$EMACS >/dev/null; then \
set -e; \
@@ -508,7 +492,7 @@
local.h:
set +e; [ -r local.h ] || cp local.h.samp local.h
-msgs.h: config.sh FRC
+msgs.h: config.sh
@. ./config.sh; \
set $(SHELLDEBUG); \
set +e; \
@@ -522,7 +506,8 @@
else \
set -x; \
rm -f msgs.h; ln $$msgs msgs.h || cp $$msgs msgs.h; \
- fi
+ fi; \
+ touch msgs.h
FRC: