pkgsrc/devel/subversion/patches/patch-ae
adam c757e6a2a8 Version 1.9.0
User-visible changes:
- General:
  * make all commands provide brief description in help output (r1522518)
  * flush stdout before exiting to avoid information being lost (r1543868)

- Major new features:
  * fsfs: new format 7 with more efficient on-disk layout (r1547045 et al)
  * resolve: improve interactive conflict resolution menus
  * blame: support showing prospective as well as previous changes
  * info: support printing of individual values with --show-item (r1662620)
  * svn auth: new subcommand to manage cached credentials and certs
  * svnserve: cache config and authz to lower resource usage and be able to
    serve large numbers of connections with a limited number of threads
  * membuffer: quadruple the maximum cacheable directory size (r1545948 et al)
  * new filesystem fsx (faster, smaller); experimental - see release notes

- Minor new features and improvements:
See http://svn.apache.org/repos/asf/subversion/tags/1.9.0/CHANGES
2015-08-13 20:47:41 +00:00

18 lines
924 B
Text

$NetBSD: patch-ae,v 1.22 2015/08/13 20:47:42 adam Exp $
* tell location of libraries from subversion base package.
--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2014-01-17 04:54:43.000000000 +0000
+++ subversion/bindings/swig/perl/native/Makefile.PL.in
@@ -35,9 +35,11 @@ my $svnlib_srcdir = "${top_srcdir}/subve
my $svnlib_builddir = "${top_builddir}/subversion";
my $swig_srcdir = "${svnlib_srcdir}/bindings/swig";
my $swig_builddir = "${svnlib_builddir}/bindings/swig";
+my $subversion_base_lib = $ENV{SUBVERSION_BASE_PREFIX} . "/lib";
my @modules = qw/client delta fs ra repos wc/;
my @ldpaths = (abs_path($swig_builddir) . "/perl/libsvn_swig_perl/.libs",
+ $subversion_base_lib,
map { abs_path($svnlib_builddir) . "/libsvn_$_/.libs" }
@modules, qw/diff subr ra_local ra_svn ra_serf
fs_base fs_util fs_fs fs_x/);