pkgsrc/www/ap2-xslt2/patches/patch-ab
xtraeme aca495c729 Initial import of ap2-xslt2 (known as mod-xslt2).
mod-xslt2 is a server side module able to transform ``xml''
documents in ``html'' (or to any other format) before they
even get back to the browser.

mod-xslt2 main features include:

* Ability to parse generated xml (ability to parse the output of
  php or perl scripts).

* Ability to use the ``xslt'' indicated by the <?xml-stylesheet
  processing instruction.

* Ability to send back the xml file unparsed to the browser.

* Ability to fetch xslt or DTDs from scripts rather than from
  static files.

* Ability to fetch a different xslt depending on the content of
  the request headers, of the get parameters or the web server
  environment.

* Ability to allow xslt stylesheets to make use of these
  variables to generate output.

--
http://www.mod-xslt2.com/
2006-12-07 02:34:01 +00:00

23 lines
1.1 KiB
Text

$NetBSD: patch-ab,v 1.1.1.1 2006/12/07 02:34:01 xtraeme Exp $
--- lib/Makefile.in.orig 2004-10-02 10:24:02.000000000 +0200
+++ lib/Makefile.in 2006-12-07 02:53:57.000000000 +0100
@@ -156,13 +156,13 @@
install: install-library install-headers
install-library: libmodxslt$(LIB_VERSION).la
- $(LIBTOOL) --mode=install install $(IFLAGS) -D -m 0644 -o root -g root \
- libmodxslt$(LIB_VERSION).la $(DESTDIR)$(libdir)/libmodxslt$(LIB_VERSION).la
+ $(LIBTOOL) --mode=install $(BSD_INSTALL_LIB) \
+ libmodxslt$(LIB_VERSION).la $(DESTDIR)$(libdir)
install-headers:
- $(INSTALL) -d -m 0755 -o root -g root $(DESTDIR)$(includedir)/modxslt$(LIB_VERSION)
- $(INSTALL) -m 0644 -o root -g root $(srcdir)/modxslt$(LIB_VERSION)/*.h $(DESTDIR)$(includedir)/modxslt$(LIB_VERSION)
- $(INSTALL) -m 0644 -o root -g root ./modxslt$(LIB_VERSION)/*.h $(DESTDIR)$(includedir)/modxslt$(LIB_VERSION)
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(includedir)/modxslt2
+ $(BSD_INSTALL_DATA) $(srcdir)/modxslt$(LIB_VERSION)/*.h $(DESTDIR)$(includedir)/modxslt2
+ $(BSD_INSTALL_DATA) ./modxslt$(LIB_VERSION)/*.h $(DESTDIR)$(includedir)/modxslt2
uninstall: uninstall-library uninstall-headers