pkgsrc/mail/courier-auth/patches/patch-af
jlam 3eada221c5 Initial import of mail/courier-auth-0.37.1.
This package contains the authentication daemon, modules, and utilities
for the Courier mail packages.
2002-01-22 22:00:22 +00:00

36 lines
1 KiB
Text

$NetBSD: patch-af,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
--- userdb/Makefile.in.orig Fri Jan 18 22:04:41 2002
+++ userdb/Makefile.in
@@ -332,9 +332,31 @@
$(MAKE) $(AM_MAKEFLAGS) all-recursive
install-exec-am:
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
+ $(INSTALL_PROGRAM) userdbpw $(DESTDIR)$(sbindir)/userdbpw
+ $(mkinstalldirs) $(DESTDIR)$(datadir)
+ cp userdb.pl userdb
+ for f in makeuserdb userdb pw2userdb vchkpw2userdb; do \
+ $(INSTALL_SCRIPT) $$f $(DESTDIR)$(datadir)/$$f; \
+ rm -f $(DESTDIR)$(sbindir)/$$f; \
+ $(LN_S) $(datadir)/$$f $(DESTDIR)$(sbindir)/$$f; \
+ done
+
install-exec: install-exec-am
+man8dir = @mandir@/man8
+
install-data-am:
+ $(mkinstalldirs) $(DESTDIR)$(man8dir)
+ for i in $(man8); do \
+ echo " $(INSTALL_DATA) $$i $(DESTDIR)$(man8dir)/$$i"; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(man8dir)/$$i; \
+ done
+ cd $(DESTDIR)$(man8dir) ; \
+ rm -f pw2userdb.8 vchkpw2userdb.8; \
+ $(LN_S) makeuserdb.8 pw2userdb.8 ; \
+ $(LN_S) makeuserdb.8 vchkpw2userdb.8 ; \
+
install-data: install-data-am
install-am: all-am