pkgsrc/wm/pwm/patches/patch-ag
salo 3e8ac8d07f Updated to 20060517 snapshot.
Changes:

- add my theme file,
- delint.

20060517:

- Applied a crash patch to thing.c by Ben Stern.
2006-06-02 11:21:28 +00:00

71 lines
1.9 KiB
Text

$NetBSD: patch-ag,v 1.7 2006/06/02 11:21:29 salo Exp $
--- system.mk.orig 2006-05-17 08:50:33.000000000 +0200
+++ system.mk 2006-06-02 12:55:38.000000000 +0200
@@ -7,13 +7,13 @@
## Installation paths
##
-PREFIX=/usr/local
+#PREFIX=/usr/local
# No need to modify these usually
BINDIR=$(PREFIX)/bin
-ETCDIR=$(PREFIX)/etc
+ETCDIR=$(PREFIX)/share/examples
MANDIR=$(PREFIX)/man
-DOCDIR=$(PREFIX)/doc
+DOCDIR=$(PREFIX)/share/doc
# Not used
INCDIR=$(PREFIX)/include
LIBDIR=$(PREFIX)/lib
@@ -23,7 +23,7 @@ LIBDIR=$(PREFIX)/lib
## X libraries, includes and options
##
-X11_PREFIX=/usr/X11R6
+X11_PREFIX=$(X11BASE)
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
@@ -40,7 +40,7 @@ X11_DEFINES=
## C compiler
##
-CC=gcc
+#CC=gcc
# The POSIX_SOURCE, XOPEN_SOURCE and WARN options should not be necessary,
# they're mainly for development use. So, if they cause trouble (not
@@ -49,26 +49,26 @@ CC=gcc
# libtu/ uses POSIX_SOURCE
-POSIX_SOURCE=-ansi -D_POSIX_SOURCE
+POSIX_SOURCE=-D_POSIX_SOURCE -D_ISOC99_SOURCE
# and . (ion) XOPEN_SOURCE.
# There is variation among systems what should be used and how they interpret
# it so it is perhaps better not using anything at all.
# Most systems
-#XOPEN_SOURCE=-ansi -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D__EXTENSIONS__
# sunos, (irix)
#XOPEN_SOURCE=-ansi -D__EXTENSIONS__
# Same as '-Wall -pedantic-errors' without '-Wunused' as callbacks often
# have unused variables.
-WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
+#WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
-Wtrigraphs -Wformat -Wchar-subscripts \
-Wparentheses -Wuninitialized
# -pedantic-errors
-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
+CFLAGS+=-g $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+LDFLAGS+=-g $(LIBS) $(EXTRA_LIBS)
##