Version 0.20.2 - April 2020 * Improvements for maintainers: - A dependency bug in po/Makefile.in.in has been fixed. * Programming languages support: - Shell: o The programs 'gettext', 'ngettext', when invoked with option -e, now expand '\\' and octal escape sequences, instead of swallowing them. (Bug present since the beginning.) o xgettext now recognizes 'gettext' program invocations with the '-e' option, such as gettext -e 'some\nstring\n' - Python: xgettext now assumes a Python source file is in UTF-8 encoding by default, as stated in PEP 3120. - Desktop Entry: The value of the 'Icon' property is no longer extracted into the POT file by xgettext. The documentation explains how to localize icons. * Runtime behaviour: - The interpretation of the language preferences on macOS has been improved, especially in the case where a system locale does not exist for the combination of the selected primary language and the selected territory. - Fixed a multithread-safety bug on Cygwin and native Windows.
35 lines
1 KiB
Text
35 lines
1 KiB
Text
$NetBSD: patch-ag,v 1.11 2020/04/20 08:37:14 wiz Exp $
|
|
|
|
--- gettext-tools/gnulib-lib/Makefile.in.orig 2020-04-14 04:46:29.000000000 +0000
|
|
+++ gettext-tools/gnulib-lib/Makefile.in
|
|
@@ -3483,13 +3483,13 @@ info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-pkgdataDATA
|
|
+install-data-am:
|
|
|
|
install-dvi: install-dvi-am
|
|
|
|
install-dvi-am:
|
|
|
|
-install-exec-am: install-exec-local install-libLTLIBRARIES
|
|
+install-exec-am: install-libLTLIBRARIES
|
|
|
|
install-html: install-html-am
|
|
|
|
@@ -3767,14 +3767,6 @@ getopt-cdefs.h: getopt-cdefs.in.h $(top_
|
|
} > $@-t && \
|
|
mv -f $@-t $@
|
|
|
|
-# No need to install libgettextlib.a, except on AIX.
|
|
-install-exec-local: install-libLTLIBRARIES install-exec-clean
|
|
-install-exec-clean:
|
|
- case "@host_os@" in \
|
|
- aix*) ;; \
|
|
- *) rm -f $(DESTDIR)$(libdir)/libgettextlib.a ;; \
|
|
- esac
|
|
-
|
|
# We need the following in order to create <iconv.h> when the system
|
|
# doesn't have one that works with the given compiler.
|
|
@GL_GENERATE_ICONV_H_TRUE@iconv.h: iconv.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H) $(WARN_ON_USE_H)
|