pkgsrc/devel/xulrunner/patches/patch-mf
tnn 941c15b90a Update to firefox-3.6.2.
.2 is not formally released yet, but is release tagged in the scm and I
want to get this update in before we freeze the tree.

"Firefox 3.6 is built on Mozilla's Gecko 1.9.2 web rendering platform,
which has been under development since early 2009 and contains many
improvements for web developers, add-on developers, and users."

- Improved JavaScript performance, overall browser responsiveness,
  and startup time.
- The ability for web developers to indicate that scripts should run
  asynchronously to speed up page load times.
- Continued support for downloadable web fonts using the new WOFF font format.
- Support for new CSS attributes such as gradients, background sizing,
  and pointer events.
- Support for new DOM and HTML5 specifications including the Drag & Drop API
  and the File API, which allow for more interactive web pages.
2010-03-16 15:57:02 +00:00

21 lines
755 B
Text

$NetBSD: patch-mf,v 1.3 2010/03/16 15:57:02 tnn Exp $
Add DragonFly support.
Make sure nss libraries have a run path defined.
--- security/coreconf/config.mk.orig 2010-03-15 14:56:04.000000000 +0000
+++ security/coreconf/config.mk
@@ -63,7 +63,7 @@ endif
#######################################################################
TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \
- AIX RISCOS WINNT WIN95 WINCE
+ AIX RISCOS WINNT WIN95 WINCE DragonFly
ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
@@ -207,3 +207,4 @@ endif
DEFINES += -DUSE_UTIL_DIRECTLY
USE_UTIL_DIRECTLY = 1
+EXTRA_SHARED_LIBS += -Wl,-R${PREFIX}/lib/${MOZILLA_PKG_NAME}