98 lines
3 KiB
Text
98 lines
3 KiB
Text
$NetBSD: patch-ab,v 1.1.1.1 2006/04/06 16:45:34 drochner Exp $
|
|
|
|
--- setup.py.orig 2006-03-12 01:11:40.000000000 +0100
|
|
+++ setup.py
|
|
@@ -21,23 +21,23 @@ rc = dict({'backend':'PS', 'numerix':'Nu
|
|
# numarray. You can build the image module with either Numeric or
|
|
# numarray or both. By default, matplotlib will build support for
|
|
# whatever array packages you have installed.
|
|
-BUILD_IMAGE = 1
|
|
+BUILD_IMAGE = 0
|
|
|
|
# Build the antigrain geometry toolkit. Agg makes heavy use of
|
|
# templates, so it probably requires a fairly recent compiler to build
|
|
# it. It makes very nice antialiased output and also supports alpha
|
|
# blending
|
|
-BUILD_AGG = 1
|
|
-BUILD_GTKAGG = 'auto'
|
|
-BUILD_GTK = 'auto'
|
|
+BUILD_AGG = 0
|
|
+BUILD_GTKAGG = 1
|
|
+BUILD_GTK = 1
|
|
|
|
# build TK GUI with Agg renderer ; requires Tkinter Python extension
|
|
# and Tk includes
|
|
# Use False or 0 if you don't want to build
|
|
-BUILD_TKAGG = 'auto'
|
|
+BUILD_TKAGG = 0
|
|
|
|
# build wxPython GUI with Agg renderer ; requires wxPython package
|
|
-BUILD_WXAGG = 'auto'
|
|
+BUILD_WXAGG = 0
|
|
|
|
|
|
# build a small extension to manage the focus on win32 platforms.
|
|
@@ -137,7 +137,7 @@ rc['numerix'] = NUMERIX[-1]
|
|
ext_modules = []
|
|
|
|
# these are not optional
|
|
-BUILD_FT2FONT = 1
|
|
+BUILD_FT2FONT = 0
|
|
BUILD_CONTOUR = 1
|
|
|
|
# jdh
|
|
@@ -164,7 +164,7 @@ try: import datetime
|
|
except ImportError: havedate = False
|
|
else: havedate = True
|
|
|
|
-if havedate: # dates require python23 datetime
|
|
+if 0: # dates require python23 datetime
|
|
# only install pytz and dateutil if the user hasn't got them
|
|
def add_pytz():
|
|
packages.append('pytz')
|
|
@@ -190,9 +190,9 @@ if havedate: # dates require python23 da
|
|
except ImportError:
|
|
add_pytz()
|
|
|
|
-build_swigagg(ext_modules, packages)
|
|
-build_transforms(ext_modules, packages, NUMERIX)
|
|
-build_enthought(ext_modules, packages)
|
|
+#build_swigagg(ext_modules, packages)
|
|
+#build_transforms(ext_modules, packages, NUMERIX)
|
|
+#build_enthought(ext_modules, packages)
|
|
|
|
if BUILD_GTK:
|
|
try:
|
|
@@ -238,7 +238,7 @@ if BUILD_GTKAGG:
|
|
print 'pygtk present but import failed'
|
|
|
|
if BUILD_GTKAGG:
|
|
- BUILD_AGG = 1
|
|
+ BUILD_AGG = 0
|
|
build_gtkagg(ext_modules, packages, NUMERIX)
|
|
rc['backend'] = 'GTKAgg'
|
|
|
|
@@ -257,7 +257,7 @@ if BUILD_WINDOWING and sys.platform=='wi
|
|
if BUILD_IMAGE:
|
|
build_image(ext_modules, packages, NUMERIX)
|
|
|
|
-if 1: # I don't think we need to make these optional
|
|
+if 0: # I don't think we need to make these optional
|
|
build_contour(ext_modules, packages, NUMERIX)
|
|
|
|
for mod in ext_modules:
|
|
@@ -290,11 +290,11 @@ distrib = setup(name="matplotlib",
|
|
object oriented, there is a functional interface "pylab"
|
|
for people coming from Matlab.
|
|
""",
|
|
- packages = packages,
|
|
+# packages = packages,
|
|
platforms='any',
|
|
- py_modules = ['pylab'],
|
|
+# py_modules = ['pylab'],
|
|
ext_modules = ext_modules,
|
|
- data_files = data_files,
|
|
+# data_files = data_files,
|
|
package_dir = {'': 'lib'},
|
|
cmdclass = {'install_data':smart_install_data},
|
|
**additional_params
|