50cacd0bcf
NEWS for the 2.2 release Licensing change: * Relicensed as LGPL v2.1 or later (user's option). * Replaced blowfish and serpent implementation. New code is based on the LGPLed code in libgcrypt. New features: * Support for Galois/Counter Mode (GCM). * New interface for enumerating (most) available algorithms, contributed by Daniel Kahn Gillmor. * New tool nettle-hash. Can generate hash digests using any supported hash function, with output compatible with md5sum and friends from GNU coreutils. Checking (like md5sum -c) not yet implemented. Bug fixes: * The old serpent code had a byte order bug (introduced by yours truly about ten years ago). New serpent implementation does not interoperate with earlier versions of nettle. * Fixed ABI-dependent libdir default for Linux-based systems which do not follow the Linux File Hierarchy Standard, e.g., Debian GNU/Linux. Optimizations: * x86_64 implemention of serpent. * x86_64 implemention of camellia. * Optimized memxor using word rather than byte operations. Both generic C and x86_64 assembler. * Eliminated a memcpy for in-place CBC decrypt. Miscellaneous: * In command line tools, no longer support -? for requesting help, since using it without shell quoting is a dangerous habit. Use long option --help instead. The shared library names are libnettle.so.4.1 and libhogweed.so.2.1, with sonames libnettle.so.4 and libhogweed.so.2.
26 lines
910 B
Text
26 lines
910 B
Text
$NetBSD: patch-testsuite_Makefile.in,v 1.2 2011/08/22 15:09:21 wiz Exp $
|
|
|
|
Use LIBTOOL.
|
|
|
|
--- testsuite/Makefile.in.orig 2011-07-11 13:59:25.000000000 +0000
|
|
+++ testsuite/Makefile.in
|
|
@@ -64,8 +64,8 @@ all: $(TARGETS) $(EXTRA_TARGETS)
|
|
# to use suffix rules to build the test executables. So we use an
|
|
# explicit rule for each and every executable.
|
|
|
|
-LIB_HOGWEED = @IF_HOGWEED@ -lhogweed
|
|
-TEST_OBJS = testutils.$(OBJEXT) $(LIB_HOGWEED) -lnettle $(LIBS)
|
|
+LIB_HOGWEED = @IF_HOGWEED@ ../libhogweed.la
|
|
+TEST_OBJS = testutils.$(OBJEXT) $(LIB_HOGWEED) ../libnettle.la $(LIBS)
|
|
|
|
.PHONY: test-rules
|
|
test-rules:
|
|
@@ -83,7 +83,7 @@ test-rules:
|
|
include $(srcdir)/.test-rules.make
|
|
|
|
$(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) \
|
|
- ../libnettle.a @IF_HOGWEED@ ../libhogweed.a
|
|
+ ../libnettle.la @IF_HOGWEED@ ../libhogweed.la
|
|
|
|
# The PATH update is for locating dlls on w*ndows.
|
|
check: $(TS_ALL) $(srcdir)/run-tests
|