- Convert to use bsd.options.mk. - The virus database has been moved to ${VARBASE}/clamav. * freshclam/clamd: fix crash on PPC when LogFile was enabled together with LogSyslog * configure: improve gethostbyname_r check; cleanups * clamav-milter: Use GETHOSTBYNAME_R_6 Better load balancing if max_children = 0 Fixed warning message when building on FreeBSD4.9 Closed (small) memory leak Fix crash when the 1st remote service goes down Only use gethostbyname_r on LINUX for now Improved load balancing a bit * clamdscan: fix stdin scanning in local mode * clamav-milter: %v in the template file handling is now replaced only with the virus name, no "stream:" appears * libclamav/mbox.c: Fix crash when debugging on SPARC * libclamav/message.c: Fix occasional crash when scanning multipart within multipart e-mails
22 lines
1.2 KiB
Text
22 lines
1.2 KiB
Text
$NetBSD: patch-af,v 1.1 2004/08/01 04:35:33 jlam Exp $
|
|
|
|
--- database/Makefile.in.orig Thu Jul 29 17:50:06 2004
|
|
+++ database/Makefile.in
|
|
@@ -344,17 +344,6 @@ install:
|
|
@test -f $(DESTDIR)$(DBINST)/mirrors.txt && rm -f $(DESTDIR)$(DBINST)/mirrors.txt || true
|
|
@test -f $(DESTDIR)$(DBINST)/viruses.db && rm -f $(DESTDIR)$(DBINST)/viruses.db || true
|
|
@test -f $(DESTDIR)$(DBINST)/viruses.db2 && rm -f $(DESTDIR)$(DBINST)/viruses.db2 || true
|
|
- @if test `id|sed -e 's/^.[^(]*(\([^)]*\)).*/\1/'` = "root" && test -n "${CLAMAVUSER}" && test -n "${CLAMAVGROUP}"; then \
|
|
- chmod 775 $(DESTDIR)$(DBINST); \
|
|
- chown ${CLAMAVUSER} $(DESTDIR)$(DBINST); \
|
|
- chgrp ${CLAMAVGROUP} $(DESTDIR)$(DBINST); \
|
|
- chmod 664 $(DESTDIR)$(DBINST)/main.cvd; \
|
|
- chown ${CLAMAVUSER} $(DESTDIR)$(DBINST)/main.cvd; \
|
|
- chgrp ${CLAMAVGROUP} $(DESTDIR)$(DBINST)/main.cvd; \
|
|
- chmod 664 $(DESTDIR)$(DBINST)/daily.cvd; \
|
|
- chown ${CLAMAVUSER} $(DESTDIR)$(DBINST)/daily.cvd; \
|
|
- chgrp ${CLAMAVGROUP} $(DESTDIR)$(DBINST)/daily.cvd; \
|
|
- fi
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|