pkgsrc/devel/ldapsdk/patches/patch-af
joerg 644ab6d226 Add DragonFly support. Make the pre-install script a bit more likely
to work on NetBSD platforms by not hard-coding NetBSD.
Use BSD_INSTALL_LIB for shared libraries, better file mods.
2006-01-15 18:10:23 +00:00

18 lines
424 B
Text

$NetBSD: patch-af,v 1.1 2006/01/15 18:10:23 joerg Exp $
--- nsprpub/pr/tests/Makefile.orig 2006-01-15 17:55:06.000000000 +0000
+++ nsprpub/pr/tests/Makefile
@@ -331,6 +331,13 @@ endif
LDOPTS += -Xlinker -R $(PWD)/$(DIST)/lib
endif
+ifeq ($(OS_ARCH),DragonFly)
+ifeq ($(USE_PTHREADS),1)
+EXTRA_LIBS = -pthread
+endif
+LDOPTS += -Xlinker -R $(PWD)/$(DIST)/lib
+endif
+
ifeq ($(OS_ARCH),BSD_OS)
EXTRA_LIBS = -ldl
endif