pkgsrc/math/scilab/patches/patch-aa
dmcmahill 5b037ff914 update to scilab-2.7.
Main Changes Scilab 2.6 -> 2.7
		     ==============================
THANKS
======
Scilab group wants to thank the increasing number of people who have
contributed to this new version of Scilab, with special mention to
Anders Blomdell, Stephane Mottelet, Dan McMahill
Ton van Overbeek, Bruno Pincon and Enrico Segre.


NEW FUNCTIONALITIES
===================
Slicot based control routines (www.win.tue.nl/wgs/slicot.html)
have been introduced with a special attention
to identification functions, lyapunov, sylvester and riccati equation solvers.

Interface with TeXmacs (www.texmacs.org) a high level scientific text editor.
The editor allows you to write structured documents via a wysiwyg interface
including Scilab sessions and results.

An embedded text editor scipad derived from TkNotepad
(www.mindspring.com/~joeja/programs.html) as been developped.

C Code generation from Scicos discrete models

Blocks defining DAE are now usable in Scicos.

Statistic toolbox added (labostat).

A new graphics version based on objects and entities has been developped
(beta version). It allows to edit the properties of graphics
objects. By default, the old graphics version is used. Tu use the new graphics
version see the help of "graphics_entities".

OTHERS IMPROVEMENTS
===================
Linear algebra primitives now based on Lapack instead of Linpack/Eispack.

Basic functions revised (thanks to B Pincon).

stacksize use is no more restricted.

Hypertext, xml based, online help.

Binary Matlab file .mat loader (loadmatfile) added.

Possibility to customize graphics window event handlers (seteventhandler).

edit_graph, a graph editor for Metanet toolbox, written in Scilab, replaces
xmetanet. It works on both Unix and Windows.

INCOMPATIBLITIES
================
It is higly recommended to rebuild user's scilab functions libraries. This
can be done as follow:
predef(0);genlib('mylib','mylib_path',%t)

gschur and gspec functions are now obsolete and replaced by schur and spec.

Geci and the communication library have been removed. Use PVM interface instead.

Metanet graph editor has been rewritten. Use edit_graph instead.

man pages have to be written in HTML or better in XML but chapters
written in the old ascii files are still handled.

Scicos internal data structure have been changed. Automatic translation
is made when  old diagrams are loaded.
2003-02-22 04:31:03 +00:00

11 lines
410 B
Text

$NetBSD: patch-aa,v 1.7 2003/02/22 04:31:06 dmcmahill Exp $
--- configure.in.orig Thu Feb 20 22:05:02 2003
+++ configure.in Fri Feb 21 06:46:43 2003
@@ -992,5 +992,5 @@
FC_OPTIONS="${FFLAGS}"
FC_OPTIONS_O0=`echo $FC_OPTIONS | sed 's/-O[0-9]*//g'`
- FC_LDFLAGS="${LDLAGS} -Wl,-R${X11BASE}/lib"
+ FC_LDFLAGS="${LDFLAGS} -Wl,-R${X11BASE}/lib"
FC_PICFLAGS='-fPIC'
# check for --export-dynamic