pkgsrc/devel/hdf/patches/patch-ae
jtb f8a0903fc5 Update to version 4.1r5.
New Features and Changes:
========================

o The following Vdata routines were added:

     VSsetblocksize/vsfsetblsz -- sets the block size of the
                                  linked-block element.
     VSsetnumblocks/vsfsetnmbl -- sets the number of blocks for
                                  a linked-block element.
     VSgetblockinfo/vsfgetblinfo -- retrieves the block size and the number
                                    of blocks of a linked-block element.

o  Two routines were added to get compression information for the SD and
   GR interfaces, including chunked elements: SDgetcompress/sfgcompress
   and GRgetcompress/mggcompress.

   Note:

   - For a JPEG image, GRgetcompress only returns the compression type, not
     the compression information (i.e, quantity and force_baseline).  This
     information is not currently retrievable.

   - Getting compression type for JPEG chunked images is not working yet.

o  "hdp dumpgr" has a new option, -pd, to print palette data only.  Also,
   whenever option -p or -pd is given, only palettes are printed, and no
   images or file attributes.

o  A new FORTRAN function, heprntf (HEprint), was added.  It takes two
   arguments: file name and level.  If the file name string has 0 length,
   then error messages will be printed to standard output.

o  A memory leak in the netCDF portion of the HDF/mfhdf distribution
   was fixed.

o  The "#define NULL" was removed since ANSI C compilers are required to
   define NULL.

o  When using "hdp dumpgr", data was being printed in the range of 0-250
   when it should have been between 0-168.  This problem is now fixed.
2002-05-03 23:14:52 +00:00

87 lines
2.2 KiB
Text

$NetBSD: patch-ae,v 1.5 2002/05/03 23:14:52 jtb Exp $
--- /dev/null Wed May 1 14:04:01 2002
+++ hdf/util/Makefile Wed May 1 14:07:48 2002
@@ -0,0 +1,82 @@
+UTILS= hdf24to8 hdfcomp hdfed hdfls hdfpack hdftopal hdftor8 \
+ paltohdf r8tohdf ristosds vmake vshow hdf8to24 \
+ hdf2jpeg jpeg2hdf fp2hdf hdfunpac vcompat
+
+all: ${UTILS}
+
+BINDIR= ${PREFIX}/bin
+LIBDIR= ${PREFIX}/lib
+
+CPPFLAGS+= -Dunix
+CPPFLAGS+= -I${.CURDIR}/../src
+
+LDFLAGS+= -L${.CURDIR}/../src
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.jpeg}/lib
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.zlib}/lib
+
+LDADD+= -ldf -ljpeg -lz
+
+NOGCCERROR= 1
+
+fp2hdf: fp2hdf.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -lm -o $@
+
+hdf24to8: hdf24to8.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdf2jpeg: hdf2jpeg.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdf8to24: hdf8to24.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdfcomp: hdfcomp.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdfed: he_main.o he_cntrl.o he_disp.o he_file.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdfls: hdfls.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdfpack: hdfpack.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdftopal: hdftopal.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdftor8: hdftor8.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+hdfunpac: hdfunpac.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+jpeg2hdf: jpeg2hdf.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+paltohdf: paltohdf.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+r8tohdf: r8tohdf.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+ristosds: ristosds.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+vcompat: vcompat.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+vmake: vmake.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+vshow: vshow.o
+ ${CC} ${CPPFLAGS} ${CFLAGS} $? ${LDFLAGS} ${LDADD} -o $@
+
+
+install: ${UTILS}
+ @for f in ${UTILS}; do \
+ ${BSD_INSTALL_PROGRAM} $$f ${BINDIR}; \
+ done
+
+clean:
+ -rm -f *.o ${UTILS}