e2afa97f51
buildlink2.mk files back into the main trunk. This provides sufficient buildlink2 infrastructure to start merging other packages from the buildlink2 branch that have already been converted to use the buildlink2 framework.
18 lines
584 B
Text
18 lines
584 B
Text
$NetBSD: patch-ae,v 1.5 2002/08/25 18:39:12 jlam Exp $
|
|
|
|
--- imlib-config.in.orig Tue Mar 27 22:18:40 2001
|
|
+++ imlib-config.in
|
|
@@ -58,11 +58,11 @@
|
|
echo `@GTK_CONFIG@ --cflags` $includes @X_CFLAGS@
|
|
;;
|
|
--libs)
|
|
- libdirs=-L@libdir@
|
|
+ libdirs="-L@libdir@ -Wl,-R@libdir@"
|
|
echo $libdirs -lImlib @LDFLAGS@ $gx_libs @X_LIBS@ @X_PRE_LIBS@ -lXext -lX11 @X_EXTRA_LIBS@
|
|
;;
|
|
--libs-gdk)
|
|
- libdirs=-L@libdir@
|
|
+ libdirs="-L@libdir@ -Wl,-R@libdir@"
|
|
echo $libdirs -lgdk_imlib$gdk_gx_libs `@GTK_CONFIG@ --libs` $gdk_libs
|
|
;;
|
|
*)
|