changelog 1.0.41-1.0.43: Added the YacasNotebook directory with the emacs shell to the repository. We have support for BeOS! Thanks to Eugenia Loli. Serious bugfix: the ^ operator wasn't working like it should. It was mapped to BitXor, and its precedence was wrong. Allowed CForm to accept if (predicate) body; and if (predicate) body else other; These routines need to be written still, however, for them to also work in Yacas itself. cleaned up some code. Speedup of 40% of general Yacas execution. Some improvements to the logic theorem prover so it can handle (a>b)-type epressions. added support for annotating expressions, with GetExtraInfo and SetExtraInfo. Initial checkin into sourceforge CVS. Thanks to Vladimir Livshits! Fixed some windows compilation problems. ElfDll being explicitly mentioned in mathcommands3.cc, and explicitly including elfdll.h. added initial versions for the c-like &, | % and ^ operators, and if (...) ... else ... . This will probably make it possible in the future to write code that is a lot more readable than If(..., ..., ...). The else clause binds to the last if, just like in c. So this means you can now enter expressions like: if(3 < 3) a else if (3 > 3) b else c;
13 lines
374 B
Text
13 lines
374 B
Text
$NetBSD: patch-aa,v 1.4 2000/12/05 19:02:05 drochner Exp $
|
|
|
|
--- src/Makefile.in.orig Sun Nov 19 01:39:17 2000
|
|
+++ src/Makefile.in Tue Nov 28 11:07:23 2000
|
|
@@ -89,7 +89,7 @@
|
|
# supports elf binaries?
|
|
#
|
|
|
|
-yacas_LDFLAGS = -ldl -rdynamic
|
|
+yacas_LDFLAGS = -Wl,--export-dynamic
|
|
|
|
testnum_SOURCES = anumber.cpp grower.cpp lispstring.cpp stdstubs.cpp testnum.cpp mathutil.cpp
|
|
|