pkgsrc/devel/libtool/patches/patch-ab
joerg 416f555206 Update to libtool-2.2.6b. This switches libtool to the new main branch.
Changes are many, important for pkgsrc:
- much higher speed (up to 30% faster for the overall build of libX11)
- less magic for detection of the tag

The pkgsrc integration of f2c has been changed to be more sane.
libtool itself now depends on the f2c frontend to use proper
auto-configuration and only fakes up the library. This part is
encapsulated in mk/compiler/f2c.mk.
2009-12-15 17:35:36 +00:00

837 lines
29 KiB
Text

$NetBSD: patch-ab,v 1.64 2009/12/15 17:35:37 joerg Exp $
--- configure.orig 2009-12-15 16:46:54.000000000 +0100
+++ configure
@@ -5293,6 +5293,13 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
+ mint*)
+ # On MiNT we can support fairly large cmd lengths, but it takes
+ # a while to run the tests, so let's restrict it to something
+ # reasonable.
+ lt_cv_sys_max_cmd_len=8192;
+ ;;
+
amigaos*)
# On AmigaOS with pdksh, this test takes hours, literally.
# So we just punt and use a minimum line length of 8192.
@@ -5718,7 +5725,7 @@ newos6*)
;;
*nto* | *qnx*)
- lt_cv_deplibs_check_method=pass_all
+ lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so|S\.a)$'
;;
openbsd*)
@@ -7900,7 +7907,10 @@ for cc_temp in $compiler""; do
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
# Only perform the check for file, if the check method requires it
@@ -8210,9 +8220,11 @@ $as_echo_n "checking for $compiler optio
;;
darwin* | rhapsody*)
- # PIC is the default on this platform
+ # PIC is the default on this platform, and static linking of
+ # binaries generally doesn't work
# Common symbols not allowed in MH_DYLIB files
lt_prog_compiler_pic='-fno-common'
+ =''
;;
hpux*)
@@ -8234,6 +8246,13 @@ $as_echo_n "checking for $compiler optio
# Instead, we relocate shared libraries at runtime.
;;
+ mint*)
+ # Just because we use GCC doesn't mean we suddenly get shared libraries
+ # on systems that don't support them.
+ =no
+ enable_shared=no
+ ;;
+
msdosdjgpp*)
# Just because we use GCC doesn't mean we suddenly get shared libraries
# on systems that don't support them.
@@ -8431,6 +8450,9 @@ $as_echo_n "checking for $compiler optio
case $host_os in
# For platforms which do not support PIC, -DPIC is meaningless:
+ mint*)
+ =
+ ;;
*djgpp*)
lt_prog_compiler_pic=
;;
@@ -8930,7 +8952,7 @@ _LT_EOF
;;
netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
+ if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null && echo __G95__ | $CC -cpp -E - | grep __G95__ >/dev/null; then
archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
else
@@ -9450,6 +9472,8 @@ rm -f core conftest.err conftest.$ac_obj
;;
*nto* | *qnx*)
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
;;
openbsd*)
@@ -10064,6 +10088,7 @@ beos*)
bsdi[45]*)
version_type=linux
need_version=no
+ need_lib_prefix=no
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
finish_cmds='PATH="\$PATH:/sbin" ldconfig $libdir'
@@ -10165,9 +10190,7 @@ freebsd1*)
dynamic_linker=no
;;
-freebsd* | dragonfly*)
- # DragonFly does not have aout. When/if they implement a new
- # versioning mechanism, adjust this.
+freebsd*)
if test -x /usr/bin/objformat; then
objformat=`/usr/bin/objformat`
else
@@ -10179,7 +10202,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
need_version=no
need_lib_prefix=no
;;
@@ -10202,13 +10225,24 @@ freebsd* | dragonfly*)
shlibpath_overrides_runpath=no
hardcode_into_libs=yes
;;
- *) # from 4.6 on, and DragonFly
+ *) # from 4.6 on
shlibpath_overrides_runpath=yes
hardcode_into_libs=yes
;;
esac
;;
+dragonfly*)
+ version_type=linux
+ need_version=no
+ need_lib_prefix=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}$major'
+ shlibpath_var=LD_LIBRARY_PATH
+ shlibpath_overrides_runpath=no
+ hardcode_into_libs=yes
+ ;;
+
gnu*)
version_type=linux
need_lib_prefix=no
@@ -10280,12 +10314,7 @@ interix[3-9]*)
irix5* | irix6* | nonstopux*)
case $host_os in
nonstopux*) version_type=nonstopux ;;
- *)
- if test "$lt_cv_prog_gnu_ld" = yes; then
- version_type=linux
- else
- version_type=irix
- fi ;;
+ *) version_type=irix ;;
esac
need_lib_prefix=no
need_version=no
@@ -10376,15 +10405,14 @@ rm -f core conftest.err conftest.$ac_obj
;;
netbsd*)
- version_type=sunos
+ version_type=linux
need_lib_prefix=no
need_version=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
dynamic_linker='NetBSD (a.out) ld.so'
else
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
dynamic_linker='NetBSD ld.elf_so'
fi
@@ -10413,7 +10441,7 @@ newsos6)
;;
openbsd*)
- version_type=sunos
+ version_type=linux
sys_lib_dlsearch_path_spec="/usr/lib"
need_lib_prefix=no
# Some older versions of OpenBSD (3.3 at least) *do* need versioned libs.
@@ -10421,7 +10449,7 @@ openbsd*)
openbsd3.3 | openbsd3.3.*) need_version=yes ;;
*) need_version=no ;;
esac
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
shlibpath_var=LD_LIBRARY_PATH
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
@@ -12587,9 +12615,7 @@ else
fi
-if test -n "$CXX" && ( test "X$CXX" != "Xno" &&
- ( (test "X$CXX" = "Xg++" && `g++ -v >/dev/null 2>&1` ) ||
- (test "X$CXX" != "Xg++"))) ; then
+if test -n "$CXX" && test "X$CXX" != "Xno" ; then
ac_ext=cpp
ac_cpp='$CXXCPP $CPPFLAGS'
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -12836,7 +12862,10 @@ $RM -r conftest*
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
if test -n "$compiler"; then
@@ -13628,18 +13657,37 @@ if test -z "$aix_libpath"; then aix_libp
netbsd*)
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
+ # a.out is quite broken and goes directly to ld
archive_cmds_CXX='$LD -Bshareable -o $lib $predep_objects $libobjs $deplibs $postdep_objects $linker_flags'
wlarc=
+ # Determine if we need to override the c++rt0 that is
+ # picked up by analysing output_verbose_link_cmds
+ if test -f ${PREFIX}/lib/c++rt0/c++rt0.o.PIC; then
+ cpprt0_file="${PREFIX}/lib/c++rt0/c++rt0.o.PIC"
+ else
+ cpprt0_file=
+ fi
hardcode_libdir_flag_spec_CXX='-R$libdir'
hardcode_direct_CXX=yes
hardcode_shlibpath_var_CXX=no
- fi
- # Workaround some broken pre-1.5 toolchains
- output_verbose_link_cmd='$CC -shared $CFLAGS -v conftest.$objext 2>&1 | $GREP conftest.$objext | $SED -e "s:-lgcc -lc -lgcc::"'
+ elif $CC -dumpspecs | grep -- '-lgcc -lc -lgcc' >/dev/null; then
+ # Workaround some broken pre-1.5 ELF toolchains
+ output_verbose_link_cmd='$CC -shared $CFLAGS -v conftest.$objext 2>&1 | grep conftest.$objext | $SED -e "s:-lgcc -lc -lgcc::"'
+ else
+ # Modern ELF works sanely as-is
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
+ output_verbose_link_cmd='echo'
+ fi
;;
*nto* | *qnx*)
- ld_shlibs_CXX=yes
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
+ ='-R$libdir'
+ =yes
+ =no
+ output_verbose_link_cmd='echo'
;;
openbsd2*)
@@ -14036,6 +14084,11 @@ $RM -f confest.$objext
# PORTME: override above test on systems where it is broken
case $host_os in
+netbsd*)
+ if test -n "$cpprt0_file"; then
+ predep_objects_CXX=`eval echo $predep_objects_CXX | sed -e 's:/usr/lib/c++rt0.o:$cpprt0_file:'`
+ fi
+ ;;
interix[3-9]*)
# Interix 3.5 installs completely hosed .la files for C++, so rather than
# hack all around it, let's just trust "g++" to DTRT.
@@ -14176,9 +14229,15 @@ $as_echo_n "checking for $compiler optio
lt_prog_compiler_pic_CXX='-DDLL_EXPORT'
;;
darwin* | rhapsody*)
- # PIC is the default on this platform
+ # PIC is the default on this platform, and static linking of
+ # binaries generally doesn't work
# Common symbols not allowed in MH_DYLIB files
lt_prog_compiler_pic_CXX='-fno-common'
+ =''
+ ;;
+ *mint*)
+ # FreeMiNT does not support shared libraries at all
+ =
;;
*djgpp*)
# DJGPP does not support shared libraries at all
@@ -14246,6 +14305,9 @@ $as_echo_n "checking for $compiler optio
;;
esac
;;
+ mint*)
+ # FreeMiNT uses GNU C++
+ ;;
freebsd* | dragonfly*)
# FreeBSD uses GNU C++
;;
@@ -14443,6 +14505,9 @@ $as_echo_n "checking for $compiler optio
case $host_os in
# For platforms which do not support PIC, -DPIC is meaningless:
+ mint*)
+ =
+ ;;
*djgpp*)
lt_prog_compiler_pic_CXX=
;;
@@ -14948,6 +15013,7 @@ beos*)
bsdi[45]*)
version_type=linux
need_version=no
+ need_lib_prefix=no
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
finish_cmds='PATH="\$PATH:/sbin" ldconfig $libdir'
@@ -15048,9 +15114,7 @@ freebsd1*)
dynamic_linker=no
;;
-freebsd* | dragonfly*)
- # DragonFly does not have aout. When/if they implement a new
- # versioning mechanism, adjust this.
+freebsd*)
if test -x /usr/bin/objformat; then
objformat=`/usr/bin/objformat`
else
@@ -15062,7 +15126,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
need_version=no
need_lib_prefix=no
;;
@@ -15085,13 +15149,24 @@ freebsd* | dragonfly*)
shlibpath_overrides_runpath=no
hardcode_into_libs=yes
;;
- *) # from 4.6 on, and DragonFly
+ *) # from 4.6 on
shlibpath_overrides_runpath=yes
hardcode_into_libs=yes
;;
esac
;;
+dragonfly*)
+ version_type=linux
+ need_version=no
+ need_lib_prefix=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}$major'
+ shlibpath_var=LD_LIBRARY_PATH
+ shlibpath_overrides_runpath=no
+ hardcode_into_libs=yes
+ ;;
+
gnu*)
version_type=linux
need_lib_prefix=no
@@ -15163,12 +15238,7 @@ interix[3-9]*)
irix5* | irix6* | nonstopux*)
case $host_os in
nonstopux*) version_type=nonstopux ;;
- *)
- if test "$lt_cv_prog_gnu_ld" = yes; then
- version_type=linux
- else
- version_type=irix
- fi ;;
+ *) version_type=irix ;;
esac
need_lib_prefix=no
need_version=no
@@ -15259,15 +15329,14 @@ rm -f core conftest.err conftest.$ac_obj
;;
netbsd*)
- version_type=sunos
+ version_type=linux
need_lib_prefix=no
need_version=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
dynamic_linker='NetBSD (a.out) ld.so'
else
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
dynamic_linker='NetBSD ld.elf_so'
fi
@@ -15296,7 +15365,7 @@ newsos6)
;;
openbsd*)
- version_type=sunos
+ version_type=linux
sys_lib_dlsearch_path_spec="/usr/lib"
need_lib_prefix=no
# Some older versions of OpenBSD (3.3 at least) *do* need versioned libs.
@@ -15304,7 +15373,7 @@ openbsd*)
openbsd3.3 | openbsd3.3.*) need_version=yes ;;
*) need_version=no ;;
esac
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
shlibpath_var=LD_LIBRARY_PATH
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
@@ -15877,7 +15946,10 @@ $RM -r conftest*
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
GCC=$G77
if test -n "$compiler"; then
@@ -15971,9 +16043,11 @@ $as_echo_n "checking for $compiler optio
;;
darwin* | rhapsody*)
- # PIC is the default on this platform
+ # PIC is the default on this platform, and static linking of
+ # binaries generally doesn't work
# Common symbols not allowed in MH_DYLIB files
lt_prog_compiler_pic_F77='-fno-common'
+ =''
;;
hpux*)
@@ -15995,6 +16069,13 @@ $as_echo_n "checking for $compiler optio
# Instead, we relocate shared libraries at runtime.
;;
+ mint*)
+ # Just because we use GCC doesn't mean we suddenly get shared libraries
+ # on systems that don't support them.
+ =no
+ enable_shared=no
+ ;;
+
msdosdjgpp*)
# Just because we use GCC doesn't mean we suddenly get shared libraries
# on systems that don't support them.
@@ -16192,6 +16273,9 @@ $as_echo_n "checking for $compiler optio
case $host_os in
# For platforms which do not support PIC, -DPIC is meaningless:
+ mint*)
+ =
+ ;;
*djgpp*)
lt_prog_compiler_pic_F77=
;;
@@ -16676,7 +16760,7 @@ _LT_EOF
;;
netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
+ if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null && echo __G95__ | $CC -cpp -E - | grep __G95__ >/dev/null; then
archive_cmds_F77='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
else
@@ -17183,6 +17267,8 @@ rm -f core conftest.err conftest.$ac_obj
;;
*nto* | *qnx*)
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
;;
openbsd*)
@@ -17644,6 +17730,7 @@ beos*)
bsdi[45]*)
version_type=linux
need_version=no
+ need_lib_prefix=no
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
finish_cmds='PATH="\$PATH:/sbin" ldconfig $libdir'
@@ -17744,9 +17831,7 @@ freebsd1*)
dynamic_linker=no
;;
-freebsd* | dragonfly*)
- # DragonFly does not have aout. When/if they implement a new
- # versioning mechanism, adjust this.
+freebsd*)
if test -x /usr/bin/objformat; then
objformat=`/usr/bin/objformat`
else
@@ -17758,7 +17843,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
need_version=no
need_lib_prefix=no
;;
@@ -17781,13 +17866,24 @@ freebsd* | dragonfly*)
shlibpath_overrides_runpath=no
hardcode_into_libs=yes
;;
- *) # from 4.6 on, and DragonFly
+ *) # from 4.6 on
shlibpath_overrides_runpath=yes
hardcode_into_libs=yes
;;
esac
;;
+dragonfly*)
+ version_type=linux
+ need_version=no
+ need_lib_prefix=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}$major'
+ shlibpath_var=LD_LIBRARY_PATH
+ shlibpath_overrides_runpath=no
+ hardcode_into_libs=yes
+ ;;
+
gnu*)
version_type=linux
need_lib_prefix=no
@@ -17859,12 +17955,7 @@ interix[3-9]*)
irix5* | irix6* | nonstopux*)
case $host_os in
nonstopux*) version_type=nonstopux ;;
- *)
- if test "$lt_cv_prog_gnu_ld" = yes; then
- version_type=linux
- else
- version_type=irix
- fi ;;
+ *) version_type=irix ;;
esac
need_lib_prefix=no
need_version=no
@@ -17949,15 +18040,14 @@ rm -f core conftest.err conftest.$ac_obj
;;
netbsd*)
- version_type=sunos
+ version_type=linux
need_lib_prefix=no
need_version=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
dynamic_linker='NetBSD (a.out) ld.so'
else
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
dynamic_linker='NetBSD ld.elf_so'
fi
@@ -17986,7 +18076,7 @@ newsos6)
;;
openbsd*)
- version_type=sunos
+ version_type=linux
sys_lib_dlsearch_path_spec="/usr/lib"
need_lib_prefix=no
# Some older versions of OpenBSD (3.3 at least) *do* need versioned libs.
@@ -17994,7 +18084,7 @@ openbsd*)
openbsd3.3 | openbsd3.3.*) need_version=yes ;;
*) need_version=no ;;
esac
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
shlibpath_var=LD_LIBRARY_PATH
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
@@ -18557,7 +18647,10 @@ $RM -r conftest*
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
if test -n "$compiler"; then
@@ -18776,9 +18869,11 @@ $as_echo_n "checking for $compiler optio
;;
darwin* | rhapsody*)
- # PIC is the default on this platform
+ # PIC is the default on this platform, and static linking of
+ # binaries generally doesn't work
# Common symbols not allowed in MH_DYLIB files
lt_prog_compiler_pic_FC='-fno-common'
+ =''
;;
hpux*)
@@ -18800,6 +18895,13 @@ $as_echo_n "checking for $compiler optio
# Instead, we relocate shared libraries at runtime.
;;
+ mint*)
+ # Just because we use GCC doesn't mean we suddenly get shared libraries
+ # on systems that don't support them.
+ =no
+ enable_shared=no
+ ;;
+
msdosdjgpp*)
# Just because we use GCC doesn't mean we suddenly get shared libraries
# on systems that don't support them.
@@ -18997,6 +19099,9 @@ $as_echo_n "checking for $compiler optio
case $host_os in
# For platforms which do not support PIC, -DPIC is meaningless:
+ mint*)
+ =
+ ;;
*djgpp*)
lt_prog_compiler_pic_FC=
;;
@@ -19481,7 +19586,7 @@ _LT_EOF
;;
netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
+ if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null && echo __G95__ | $CC -cpp -E - | grep __G95__ >/dev/null; then
archive_cmds_FC='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
else
@@ -19988,6 +20093,8 @@ rm -f core conftest.err conftest.$ac_obj
;;
*nto* | *qnx*)
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
;;
openbsd*)
@@ -20449,6 +20556,7 @@ beos*)
bsdi[45]*)
version_type=linux
need_version=no
+ need_lib_prefix=no
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
finish_cmds='PATH="\$PATH:/sbin" ldconfig $libdir'
@@ -20549,9 +20657,7 @@ freebsd1*)
dynamic_linker=no
;;
-freebsd* | dragonfly*)
- # DragonFly does not have aout. When/if they implement a new
- # versioning mechanism, adjust this.
+freebsd*)
if test -x /usr/bin/objformat; then
objformat=`/usr/bin/objformat`
else
@@ -20563,7 +20669,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
need_version=no
need_lib_prefix=no
;;
@@ -20586,13 +20692,24 @@ freebsd* | dragonfly*)
shlibpath_overrides_runpath=no
hardcode_into_libs=yes
;;
- *) # from 4.6 on, and DragonFly
+ *) # from 4.6 on
shlibpath_overrides_runpath=yes
hardcode_into_libs=yes
;;
esac
;;
+dragonfly*)
+ version_type=linux
+ need_version=no
+ need_lib_prefix=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
+ soname_spec='${libname}${release}${shared_ext}$major'
+ shlibpath_var=LD_LIBRARY_PATH
+ shlibpath_overrides_runpath=no
+ hardcode_into_libs=yes
+ ;;
+
gnu*)
version_type=linux
need_lib_prefix=no
@@ -20664,12 +20781,7 @@ interix[3-9]*)
irix5* | irix6* | nonstopux*)
case $host_os in
nonstopux*) version_type=nonstopux ;;
- *)
- if test "$lt_cv_prog_gnu_ld" = yes; then
- version_type=linux
- else
- version_type=irix
- fi ;;
+ *) version_type=irix ;;
esac
need_lib_prefix=no
need_version=no
@@ -20754,15 +20866,14 @@ rm -f core conftest.err conftest.$ac_obj
;;
netbsd*)
- version_type=sunos
+ version_type=linux
need_lib_prefix=no
need_version=no
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
dynamic_linker='NetBSD (a.out) ld.so'
else
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
soname_spec='${libname}${release}${shared_ext}$major'
dynamic_linker='NetBSD ld.elf_so'
fi
@@ -20791,7 +20902,7 @@ newsos6)
;;
openbsd*)
- version_type=sunos
+ version_type=linux
sys_lib_dlsearch_path_spec="/usr/lib"
need_lib_prefix=no
# Some older versions of OpenBSD (3.3 at least) *do* need versioned libs.
@@ -20799,7 +20910,7 @@ openbsd*)
openbsd3.3 | openbsd3.3.*) need_version=yes ;;
*) need_version=no ;;
esac
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
shlibpath_var=LD_LIBRARY_PATH
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
@@ -21205,7 +21316,10 @@ for cc_temp in $compiler""; do
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
# GCJ did not exist at the time GCC didn't implicitly link libc in.
@@ -21320,9 +21434,11 @@ $as_echo_n "checking for $compiler optio
;;
darwin* | rhapsody*)
- # PIC is the default on this platform
+ # PIC is the default on this platform, and static linking of
+ # binaries generally doesn't work
# Common symbols not allowed in MH_DYLIB files
lt_prog_compiler_pic_GCJ='-fno-common'
+ =''
;;
hpux*)
@@ -21344,6 +21460,13 @@ $as_echo_n "checking for $compiler optio
# Instead, we relocate shared libraries at runtime.
;;
+ mint*)
+ # Just because we use GCC doesn't mean we suddenly get shared libraries
+ # on systems that don't support them.
+ =no
+ enable_shared=no
+ ;;
+
msdosdjgpp*)
# Just because we use GCC doesn't mean we suddenly get shared libraries
# on systems that don't support them.
@@ -21541,6 +21664,9 @@ $as_echo_n "checking for $compiler optio
case $host_os in
# For platforms which do not support PIC, -DPIC is meaningless:
+ mint*)
+ =
+ ;;
*djgpp*)
lt_prog_compiler_pic_GCJ=
;;
@@ -22025,7 +22151,7 @@ _LT_EOF
;;
netbsd*)
- if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
+ if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null && echo __G95__ | $CC -cpp -E - | grep __G95__ >/dev/null; then
archive_cmds_GCJ='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
wlarc=
else
@@ -22545,6 +22671,8 @@ rm -f core conftest.err conftest.$ac_obj
;;
*nto* | *qnx*)
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+ ='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
;;
openbsd*)
@@ -23115,7 +23243,10 @@ for cc_temp in $compiler""; do
*) break;;
esac
done
-cc_basename=`$ECHO "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
+# Return the actual command name, not our pkgsrc wrapper name because several
+# decisions are made only based on compiler names
+if test -n "$cc_temp" && new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null`; then :; else new_cc_temp="$cc_temp"; fi
+cc_basename=`$ECHO "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
lt_cv_prog_compiler_c_o_RC=yes