pkgsrc/cross/avr-gdb/patches/patch-opcodes_configure
mef e64f3c5887 (Upstream)
Bump version 7.6 to 7.6.1
 -------
GDB 7.6.1 provides the following fixes and improvements to GDB 7.6:

  * PR tdep/15420 (Cannot debug threaded programs on newer versions
    of x86-solaris - Solaris 10, Update 10 or later)
  * PR remote/15455 (QTro remote packet broken)
  * PR build/15476 (Build failure due to incomplete enum type in utils.h)
  * PR server/15594 (tls support in 64x32 x86 gdbserver doesn't extend
    address to 64 bit)
  * PR server/15075 (dprintf inteferes with "next")
  * PR server/15434 (dprintf uses a synchronous 'continue' even in
    non-stop mode)
  * PR tui/14880 (in split register layouts, up results in assertion
    failure in value.c)
  * PR c++/15519 (GDB 7.6 is 94x slower than GDB 7.5.1 using a certain
    core file)
  * PR gdb/15837 (GDB prints entry values for local variables)
  * PR gdb/15415 (gdb resolves symbolic links when passing argv[0])
  * PR cli/15603 (CTRL-C can no longer interrupt inferior)
  * PR gdb/15604 (gdbserver socket leak 7.5 regression)
2014-08-29 06:43:32 +00:00

24 lines
999 B
Text

$NetBSD: patch-opcodes_configure,v 1.2 2014/08/29 06:43:32 mef Exp $
Revert to gdb-7.5.1 to avoid following error
(But why this is necessary is unkown yet).
Configuring in ./opcodes
....
checking for gcc option to accept ISO C89... none needed
checking for library containing strerror... none required
./configure.lineno: 3236: Syntax error: Bad substitution
gmake[1]: *** [configure-opcodes] Error 1
gmake[1]: Leaving directory `/usr/pkgsrc/wip/gdb76/work/gdb-7.6'
--- opcodes/configure.orig 2013-07-03 10:59:20.000000000 +0900
+++ opcodes/configure 2013-07-03 12:02:37.000000000 +0900
@@ -3216,7 +3216,7 @@
# We currently only use the version number for the name of any shared
# library. For user convenience, we always use the same version
# number that BFD is using.
-BFD_VERSION=`${srcdir}/../bfd/configure --version | sed -n -e '1s,.* ,,p'`
+BFD_VERSION=`sed -n -e 's/^.._INIT_AUTOMAKE.*,[ ]*\([^ ]*\)[ ]*).*/\1/p' < ${srcdir}/../bfd/configure.in`
am__api_version='1.11'