a2c383d887
* backends/markup-tree.c (markup_entry_get_value): fix a logic error causing us to deref a null pointer, reported by Brian Alexander Quistorff. * configure.in: fix gtk-doc version check. * configure.in: Added Belarusian to ALL_LINGUAS. * gconf/gconf-internals.c (gconf_value_list_to_primitive_list_destructive): fix using the wrong type (value->type not value->list_type) in an error message, #96210. * gconf/gconf-internals.c (subst_variables): patch from Benn Vosseteig fixing a crash with a long path to $HOME. * doc/gconf/gconf.sgml, doc/gconf-1.0.dtd: Some additions to match the full range of schema elements curently accepted by gconftool. Supposedly complete now. * doc/Makefile.am: change the gconf-1.0.dtd install location to $(datadir)/sgml/gconf which sounds more standards compliant. * backends/markup-backend.c (resolve_address): add FIXME about. Changes in the package: * Honor PKG_SYSCONFDIR, maintaining the database inside it (PLIST do not need to care about files in etc/gconf.xml.defaults any more). * Provide a schemas.mk file that is used to automatically register .schemas files in the database. * Add a patch to handle schema deinstallation. Reviewed by wiz.
15 lines
657 B
Text
15 lines
657 B
Text
$NetBSD: patch-ab,v 1.1 2003/02/14 20:04:09 jmmv Exp $
|
|
|
|
--- Makefile.in.orig Mon Jan 27 11:12:15 2003
|
|
+++ Makefile.in
|
|
@@ -455,10 +455,6 @@ mostlyclean distclean maintainer-clean
|
|
install-data-local:
|
|
-mkdir -p $(DESTDIR)$(datadir)/aclocal
|
|
$(INSTALL_DATA) gconf.m4 $(DESTDIR)$(datadir)/aclocal/gconf-$(MAJOR_VERSION).m4
|
|
- -mkdir -p $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.defaults
|
|
- -chmod 755 $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.defaults
|
|
- -mkdir -p $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.mandatory
|
|
- -chmod 755 $(DESTDIR)$(sysconfdir)/gconf/gconf.xml.mandatory
|
|
|
|
install-schemas:
|
|
(cd standard-schemas && $(MAKE) $(AM_MAKEFLAGS) install-schemas)
|