336dce041b
Problem 1: $la and $lo would not expand with the intl/makefile I couldn't get SUBST_SED to manually replace them either. Use of MAKE_ENV also failed. Problem 2: DragonFly doesn't have base libintl. This package will not build without -lintl LDFLAG. Solution was to convert existing SUBST_SED into a patch and expand $la to "a" and $lo to "o" on the intl/Makefile.in file. Tested on both DragonFly and NetBSD
67 lines
2.5 KiB
Text
67 lines
2.5 KiB
Text
$NetBSD: patch-intl_Makefile.in,v 1.1 2012/08/08 13:11:48 marino Exp $
|
|
|
|
--- intl/Makefile.in.orig 2000-01-06 01:16:49.000000000 +0000
|
|
+++ intl/Makefile.in
|
|
@@ -62,11 +62,11 @@ SOURCES = $(COMSRCS) intl-compat.c cat-c
|
|
COMSRCS = bindtextdom.c dcgettext.c dgettext.c gettext.c \
|
|
finddomain.c loadmsgcat.c localealias.c textdomain.c l10nflist.c \
|
|
explodename.c
|
|
-OBJECTS = @INTLOBJS@ bindtextdom.$lo dcgettext.$lo dgettext.$lo gettext.$lo \
|
|
-finddomain.$lo loadmsgcat.$lo localealias.$lo textdomain.$lo l10nflist.$lo \
|
|
-explodename.$lo
|
|
-CATOBJS = cat-compat.$lo ../po/cat-id-tbl.$lo
|
|
-GETTOBJS = intl-compat.$lo
|
|
+OBJECTS = @INTLOBJS@ bindtextdom.o dcgettext.o dgettext.o gettext.o \
|
|
+finddomain.o loadmsgcat.o localealias.o textdomain.o l10nflist.o \
|
|
+explodename.o
|
|
+CATOBJS = cat-compat.o ../po/cat-id-tbl.o
|
|
+GETTOBJS = intl-compat.o
|
|
DISTFILES.common = ChangeLog Makefile.in linux-msg.sed po2tbl.sed.in \
|
|
xopen-msg.sed $(HEADERS) $(SOURCES)
|
|
DISTFILES.normal = VERSION
|
|
@@ -83,7 +83,7 @@ INCLUDES = -I.. -I. -I$(top_srcdir)/intl
|
|
|
|
all: all-@USE_INCLUDED_LIBINTL@
|
|
|
|
-all-yes: libintl.$la intlh.inst
|
|
+all-yes: libintl.a intlh.inst
|
|
all-no:
|
|
|
|
libintl.a: $(OBJECTS)
|
|
@@ -95,8 +95,8 @@ libintl.la: $(OBJECTS)
|
|
$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(OBJECTS) \
|
|
-version-info 1:0 -rpath $(libdir)
|
|
|
|
-../po/cat-id-tbl.$lo: ../po/cat-id-tbl.c $(top_srcdir)/po/$(PACKAGE).pot
|
|
- cd ../po && $(MAKE) cat-id-tbl.$lo
|
|
+../po/cat-id-tbl.o: ../po/cat-id-tbl.c $(top_srcdir)/po/$(PACKAGE).pot
|
|
+ cd ../po && $(MAKE) cat-id-tbl.o
|
|
|
|
check: all
|
|
|
|
@@ -151,8 +151,8 @@ uninstall:
|
|
info dvi:
|
|
|
|
$(OBJECTS): ../config.h libgettext.h
|
|
-bindtextdom.$lo finddomain.$lo loadmsgcat.$lo: gettextP.h gettext.h loadinfo.h
|
|
-dcgettext.$lo: gettextP.h gettext.h hash-string.h loadinfo.h
|
|
+bindtextdom.o finddomain.o loadmsgcat.o: gettextP.h gettext.h loadinfo.h
|
|
+dcgettext.o: gettextP.h gettext.h hash-string.h loadinfo.h
|
|
|
|
tags: TAGS
|
|
|
|
@@ -202,12 +202,8 @@ Makefile: Makefile.in ../config.status
|
|
# The dependency for intlh.inst is different in gettext and all other
|
|
# packages. Because we cannot you GNU make features we have to solve
|
|
# the problem while rewriting Makefile.in.
|
|
-@GT_YES@intlh.inst: intlh.inst.in ../config.status
|
|
-@GT_YES@ cd .. \
|
|
-@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
|
|
-@GT_YES@ $(SHELL) ./config.status
|
|
-@GT_NO@.PHONY: intlh.inst
|
|
-@GT_NO@intlh.inst:
|
|
+.PHONY: intlh.inst
|
|
+intlh.inst:
|
|
|
|
# Tell versions [3.59,3.63) of GNU make not to export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|