* Several man-page updates * Several buildsystem fixes * Fixed a bug with GUI icon deletion on upgrade from 2.2-RC or earlier * Change the default --tmp-dir path to a more suitable path * Improve the mysprintf() issue in openvpnserv.c * Fixed bug in port-share that could cause port share process to crash * Fix the --client-cert-not-required feature
22 lines
762 B
Text
22 lines
762 B
Text
$NetBSD: patch-ae,v 1.5 2011/04/28 07:27:25 adam Exp $
|
|
|
|
--- configure.ac.orig 2011-04-14 21:30:08.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -375,6 +375,7 @@ if test "${WIN32}" != "yes"; then
|
|
sys/mman.h fcntl.h sys/file.h stdlib.h stdint.h dnl
|
|
stdarg.h unistd.h signal.h stdio.h string.h dnl
|
|
strings.h ctype.h errno.h syslog.h pwd.h grp.h dnl
|
|
+ net/if_tap.h
|
|
net/if_tun.h net/tun/if_tun.h stropts.h sys/sockio.h dnl
|
|
netinet/in.h netinet/in_systm.h dnl
|
|
netinet/tcp.h arpa/inet.h dnl
|
|
@@ -407,6 +408,9 @@ if test "${WIN32}" != "yes"; then
|
|
#ifdef HAVE_SYS_SOCKET_H
|
|
# include <sys/socket.h>
|
|
#endif
|
|
+ #ifdef HAVE_NET_IF_H
|
|
+ # include <net/if.h>
|
|
+ #endif
|
|
#ifdef HAVE_NETINET_IN_H
|
|
# include <netinet/in.h>
|
|
#endif
|