pkgsrc/multimedia/libdv/patches/patch-aa
obache f399fb6bfa Update libdv (and tools) to 1.0.0.
2006-09-25  Dan Dennedy <dan@dennedy.org>
* libdv 1.0.0 release.

2006-09-03  Dan Dennedy <dan@dennedy.org>
* libdv/encode.c, libdv/enc_output.c: apply patch (1550898) from Craig
  Lawson to prevent noise when dv_encode_full_audio() is called with
  zero samples.

2006-08-06  Dan Dennedy <dan@dennedy.org>
* libdv/*.S: apply patch from Mike Frysinger <vapier@gentoo.org> to
  cleanup assembly symbols by hiding them and/or setting their type.
* configure.ac, Makefile.am: apply patch from Burkhard Plaum to
  automatically disable GTK-based features (playdv) when GTK+ 1.2
  is not found and to fix dist make target behavior with GTK+ disabled.
* libdv/Makefile.am: bump libtool revision.
* configure.ac: bump project version to 1.0.0.

2006-04-10  Dan Dennedy <dan@dennedy.org>
* playdv/playdv.c: bugfix segfault on exit due to dv_display_exit being
  called twice.

2006-03-06  Dan Dennedy <dan@dennedy.org>
* mmx.h: apply patches from Zan Lynx and Richard Guenther to fix x86
  compilation on gcc 4.1.

2006-01-15  Dan Dennedy <dan@dennedy.org>
* encode.c: apply patch from Burkhard Plaum to use gcc
  destructor attribute to invoke dv_cleanup() when unloading
  libdv after loading dynamically and thereby fixing a
  memory leak.

* playdv.c: bugfix segfault on exit due to dv_display_exit()
  being called twice: once in main() and second in atexit
  handler created by dv_display. Thanks for hint provided
  by Jean-Francois Panisset.

2005-01-31  Dan Dennedy <dan@dennedy.org>
* *.S: apply patch from Nicholas Miell <nmiell@gmail.com>
  to not require execution stack for assembler functions.

2004-12-20  Dan Dennedy <dan@dennedy.org>
* vlc.h, mmx.h: apply patch from Daniel Kobras to improve
  compile compatibillity by making extern inline, static inline.

2004-12-12  Dan Dennedy <dan@dennedy.org>
* *_x86_64.S: apply patch from Dean Kolosiek to fix linker
  compatibility.
2010-03-03 08:44:38 +00:00

13 lines
596 B
Text

$NetBSD: patch-aa,v 1.2 2010/03/03 08:44:39 obache Exp $
--- libdv/Makefile.in.orig 2006-09-25 20:11:48.000000000 +0000
+++ libdv/Makefile.in
@@ -61,7 +61,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgincludedir)"
libLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(lib_LTLIBRARIES)
-libdv_la_LIBADD =
+libdv_la_LIBADD = $(PTHREAD_LIBS)
am__libdv_la_SOURCES_DIST = dv.c dct.c idct_248.c weighting.c quant.c \
vlc.c place.c parse.c bitstream.c YUY2.c YV12.c rgb.c audio.c \
util.c encode.c headers.c enc_input.c enc_audio_input.c \