bd6e956758
network addresses. It support the ability to work and interact with the following: - IPv4 and IPv6 addresses and subnets - MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers - arbitrary (non-aligned) IP address ranges and IP address sets - various non-CIDR IP range formats such as nmap and glob-style formats
19 lines
500 B
Python
19 lines
500 B
Python
$NetBSD: patch-setup.py,v 1.1 2014/09/02 13:48:13 he Exp $
|
|
|
|
Prefer setup from setuptools, the older one may not
|
|
support install_requires or setup_requires
|
|
|
|
--- setup.py.orig 2014-07-06 05:19:54.000000000 +0000
|
|
+++ setup.py
|
|
@@ -8,7 +8,10 @@ A distutils Python setup file. For setup
|
|
import os
|
|
import sys
|
|
|
|
-from distutils.core import setup
|
|
+try:
|
|
+ from setuptools import setup
|
|
+except ImportError:
|
|
+ from distutils.core import setup
|
|
|
|
if os.path.exists('MANIFEST'):
|
|
os.remove('MANIFEST')
|