pkgsrc/devel/opencm/patches/patch-aa
jmc 737b3024d7 Make this put the info files into @infodir@ rather than getting cute trying
to figure out the best place. Avoids breakage if some other package
accidently creates PREFIX/share/info.
2003-04-23 23:57:58 +00:00

31 lines
1,003 B
Text

$NetBSD: patch-aa,v 1.4 2003/04/23 23:57:59 jmc Exp $
--- doc/Makefile.in.orig Wed Jan 1 07:52:58 2003
+++ doc/Makefile.in Wed Apr 23 18:30:07 2003
@@ -48,8 +48,8 @@
# work robustly when the user messes with --prefix...
# Where to put the Info files
-shareinfodir=$(findstring $(datadir)/info,$(wildcard $(datadir)/*))
-infodir = $(if $(shareinfodir),$(shareinfodir),@infodir@)
+shareinfodir= @infodir@
+infodir = @infodir@
# Where to put the manual pages.
sharemandir=$(findstring $(datadir)/man,$(wildcard $(datadir)/*))
@@ -113,12 +113,12 @@
opencm.html: opencm.texi version.texi manual/cmd-ref.texi
opencm.info: opencm.texi version.texi manual/cmd-ref.texi
-opencm-internals: opencm-internals.info.gz opencm-internals.ps opencm-internals.html
-opencm: opencm.info.gz opencm.ps opencm.html
+opencm-internals: opencm-internals.info.gz
+opencm: opencm.info.gz
%.info.gz: %.info
rm -f $@
- gzip -9 $<
+ ( unset GZIP ; ${GZIP_CMD} -9 $< )
.dvi.ps:
${DVIPS} -t letter $< -o tmp.ps