888638514a
pgsql's Makefile.shlib are patched around. ('make test' passes on netbsd-5/i386 with postgresql84.) This is a major release adding a significant number of new features including: * New "geography" type for managing geodetic (lat/lon) data * Performance-enhanced distance calculations * GML and KML format readers * Improved shape loading GUI * And more! Release Notes Important Changes * =~ operator now indicates bounding box equality, not feature equality * GEOS 3.1 is now the minimum accepted version of GEOS * GEOS 3.2 is needed if you want to use enhanced buffering features and ST_HausdorffDistance * GEOS, LibXML2, and Proj4 are now mandatory dependencies New Features * Added Hausdorff distance calculations (#209) (Vincent Picavet) * Added parameters argument to ST_Buffer operation to support one-sided buffering and other buffering styles (Sandro Santilli) * Performance improvements to ST_Distance (Nicklas Avén) * Addition of other Distance related visualization and analysis functions (Nicklas Avén) * ST_ClosestPoint * ST_DFullyWithin * ST_LongestLine * ST_MaxDistance * ST_ShortestLine * KML, GML input via ST_GeomFromGML and ST_GeomFromKML (Olivier Courtin) * Extract homogeneous collection with ST_CollectionExtract (Paul Ramsey) * Add measure values to existing linestring with ST_AddMeasure (Paul Ramsey) * History table implementation in utils (George Silva) * Win32 support and improvement of core shp2pgsql-gui (Mark Cave-Ayland) * In place 'make check' support (Paul Ramsey) * Geography type and supporting functions o Spherical algorithms from Dave Skea o Object/index implementation from Paul Ramsey o Selectivitiy implementation from Mark Cave-Ayland o Serializations (KML, GML, JSON) from Olivier Courtin o ST_Area, ST_Distance, ST_DWithin, ST_GeogFromText, ST_GeogFromWKB, ST_Intersects, ST_Covers, ST_Buffer * Documentation updates and improvements (Regina Obe, Kevin Neufeld) * Testing and quality control (Regina Obe) * PostGIS 1.5 support PostgreSQL 8.5 trunk (Guillaume Lelarge) * Many, many other changes
44 lines
1.8 KiB
Text
44 lines
1.8 KiB
Text
$NetBSD: patch-ac,v 1.2 2010/03/05 14:55:21 gdt Exp $
|
|
|
|
--- loader/Makefile.in.orig 2010-01-02 07:01:49.000000000 +0000
|
|
+++ loader/Makefile.in
|
|
@@ -39,7 +39,7 @@ ICONV_LDFLAGS=@ICONV_LDFLAGS@
|
|
ICONV_CFLAGS=@ICONV_CFLAGS@
|
|
|
|
# liblwgeom
|
|
-LIBLWGEOM=../liblwgeom/liblwgeom.a
|
|
+LIBLWGEOM=../liblwgeom/liblwgeom.la
|
|
|
|
# GTK includes and libraries
|
|
GTK_CFLAGS = @GTK_CFLAGS@
|
|
@@ -79,16 +79,16 @@ pgsql2shp.o: pgsql2shp.c
|
|
$(CC) $(CFLAGS) $(ICONV_CFLAGS) $(PGSQL_FE_CPPFLAGS) -c $<
|
|
|
|
$(PGSQL2SHP): shpopen.o dbfopen.o getopt.o pgsql2shp.o $(LIBLWGEOM)
|
|
- $(CC) $(CFLAGS) $^ $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) -lm -o $@
|
|
+ ${LIBTOOL} --mode=link $(CC) $(CFLAGS) $^ $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) -lm -o $@
|
|
|
|
$(SHP2PGSQL-CLI): stringbuffer.o shpopen.o dbfopen.o getopt.o shp2pgsql-core.o shp2pgsql-cli.o $(LIBLWGEOM)
|
|
- $(CC) $(CFLAGS) $^ -o $@ $(ICONV_LDFLAGS) -lm
|
|
+ ${LIBTOOL} --mode=link $(CC) $(CFLAGS) $^ -o $@ $(ICONV_LDFLAGS) -lm
|
|
|
|
shp2pgsql-gui.o: shp2pgsql-gui.c
|
|
$(CC) $(CFLAGS) $(PGSQL_FE_CPPFLAGS) $(GTK_CFLAGS) -o $@ -c shp2pgsql-gui.c
|
|
|
|
$(SHP2PGSQL-GUI): stringbuffer.o shpopen.o dbfopen.o shp2pgsql-core.o shp2pgsql-gui.o getopt.o $(LIBLWGEOM) $(GTK_WIN32_RES)
|
|
- $(CC) $(CFLAGS) $(GTK_WIN32_FLAGS) $^ -o $@ $(GTK_LIBS) $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) -lm
|
|
+ ${LIBTOOL} --mode=link $(CC) $(CFLAGS) $(GTK_WIN32_FLAGS) $^ -o $@ $(GTK_LIBS) $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) -lm
|
|
|
|
installdir:
|
|
@mkdir -p $(DESTDIR)$(bindir)
|
|
@@ -97,8 +97,8 @@ install: installdir
|
|
ifdef gtk_build
|
|
$(INSTALL) $(SHP2PGSQL-GUI) $(DESTDIR)$(bindir)
|
|
endif
|
|
- $(INSTALL) $(PGSQL2SHP) $(DESTDIR)$(bindir)
|
|
- $(INSTALL) $(SHP2PGSQL-CLI) $(DESTDIR)$(bindir)
|
|
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_PROGRAM} $(PGSQL2SHP) $(DESTDIR)$(bindir)
|
|
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_PROGRAM} $(SHP2PGSQL-CLI) $(DESTDIR)$(bindir)
|
|
|
|
uninstall:
|
|
@rm -f $(DESTDIR)$(bindir)/$(PGSQL2SHP)
|