pkgsrc/devel/xulrunner17/patches/patch-ipc_chromium_Makefile.in
ryoon 27af90c8a6 Import xulrunner17-17.0.2 as devel/xulrunner17.
XULRunner is a runtime environment for applications using the
XML User Interface Language, XUL. It is the successor of the "Gecko"
runtime environment.

This package tracks 17.0.x extended support release.
2013-01-10 16:17:09 +00:00

38 lines
654 B
Text

$NetBSD: patch-ipc_chromium_Makefile.in,v 1.1 2013/01/10 16:17:10 ryoon Exp $
--- ipc/chromium/Makefile.in.orig 2012-10-23 19:42:37.000000000 +0000
+++ ipc/chromium/Makefile.in
@@ -240,6 +240,33 @@ endif
endif # } OS_LINUX
+ifdef OS_BSD # {
+
+CPPSRCS += \
+ atomicops_internals_x86_gcc.cc \
+ process_util_bsd.cc \
+ time_posix.cc \
+ $(NULL)
+
+ifdef MOZ_ENABLE_GTK2
+CPPSRCS += \
+ message_pump_glib.cc \
+ $(NULL)
+endif
+
+ifdef MOZ_ENABLE_QT
+MOCSRCS = \
+ moc_message_pump_qt.cc \
+ $(NULL)
+
+CPPSRCS += \
+ $(MOCSRCS) \
+ message_pump_qt.cc \
+ $(NULL)
+endif
+
+endif # } OS_BSD
+
# libevent
ifndef MOZ_NATIVE_LIBEVENT # {