pkgsrc/x11/gtkada/patches/patch-ah
marino b7a34fc9c9 x11/gtkada: Add user guide and reference manual documentation
The majority of the documentation for gtkada was not getting built.  It
turns out that the generation step was omitted from the vendor Makefile.
For the user guide, simply adding this to the top-level makefile fixes the
problem, but the reference manual is the reason it was omitted.

The RM requires Gnat Programming Studio built with Python to generate the
documentation.  This created a circular dependency because GPS requires
gtkada to build and python is optional.  Secondly, pkgsrc-built python
verions 26 and 27 both cause GPS to core dump.  FreeBSD doesn't have this
issue, but it has a different python problem that prevents the documentation
from getting built manually on that system as well.

In the end, the latest generated RM was pulled from libre.adacore.com online
resources and packaged separately.  This is not ideal because it represents
gtkada 2.24 which has a couple of API differences from 2.22, but it's the
only full html version of the RM that can be located.

Rebuilding gtkada will result in the gtkada User Guild and Reference
Manual showing up in the <help> menu of GPS.  Currently the gtkada submenu
item has an empty submenu.
2011-10-14 14:02:17 +00:00

22 lines
2.1 KiB
Text

$NetBSD: patch-ah,v 1.1 2011/10/14 14:02:17 marino Exp $
--- configure.orig 2010-12-01 21:51:08.000000000 +0000
+++ configure
@@ -3834,7 +3834,7 @@ echo "${ECHO_T}yes" >&6
EXEC_PREFIX="$prefix"
- ac_config_files="$ac_config_files Makefile src/Makefile.common src/Makefile src/tools/gtkada-config src/tools/gate src/tools/Makefile testgtk/Makefile src/gtkextra/Makefile src/opengl/Makefile src/glade/Makefile src/gnome/Makefile docs/gtkada_ug/Makefile docs/gtkada_rm/Makefile po/Makefile src/config.h projects/gtkada.pc projects/gtkada_install_dynamic.gpr projects/gtkada_install_dynamic_gl.gpr"
+ ac_config_files="$ac_config_files Makefile src/Makefile.common src/Makefile src/tools/gtkada-config src/tools/gate src/tools/Makefile testgtk/Makefile src/gtkextra/Makefile src/opengl/Makefile src/glade/Makefile src/gnome/Makefile docs/gtkada_ug/Makefile docs/gtkada_rm_pregen/Makefile po/Makefile src/config.h projects/gtkada.pc projects/gtkada_install_dynamic.gpr projects/gtkada_install_dynamic_gl.gpr"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
@@ -4397,7 +4397,7 @@ do
"src/glade/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/glade/Makefile" ;;
"src/gnome/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/gnome/Makefile" ;;
"docs/gtkada_ug/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_ug/Makefile" ;;
- "docs/gtkada_rm/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_rm/Makefile" ;;
+ "docs/gtkada_rm_pregen/Makefile" ) CONFIG_FILES="$CONFIG_FILES docs/gtkada_rmi_pregen/Makefile" ;;
"po/Makefile" ) CONFIG_FILES="$CONFIG_FILES po/Makefile" ;;
"src/config.h" ) CONFIG_FILES="$CONFIG_FILES src/config.h" ;;
"projects/gtkada.pc" ) CONFIG_FILES="$CONFIG_FILES projects/gtkada.pc" ;;