pkgsrc/comms/efax-gtk/patches/patch-ab
adam f5dc87cd3d Changes 3.2.3:
* Provide compilation option for GTK+3 as well as GTK+2
* Make program configuration check for _POSIX_CLOCK_SELECTION as
  well as _POSIX_MONOTONIC_CLOCK when checking the availability of
  monotonic clocks for condition variables (corrects BSD builds)
* Ensure PIPE_BUF is defined in mainwindow.cpp (corrects Hurd build).
* Upgrade internal c++-gtk-utils version to 1.2.3.

Changes 3.2.2:
* Update internal copy of c++-gtk-utils to version 1.2.2 and fix
  compilation error with gcc-4.5.0.
* Provide an automatic redial option where the modem is in use or
  the recipient of a fax is busy.
* Get GUI to deal with a corner case where sending a fax from the
  socket server to an empty number (open connection) is cancelled.
* Provide an error dialog if, on program start-up, a connection to
  the dbus session message bus cannot be established.
* Use Cgu::start_timeout_seconds() instead of Cgu::start_timeout()
  where glib supports it, and so bump c++-gtk-utils requirement to
  version 1.2.1.
2010-06-10 06:44:00 +00:00

13 lines
551 B
Text

$NetBSD: patch-ab,v 1.12 2010/06/10 06:44:00 adam Exp $
--- efax/Makefile.in.orig 2010-06-10 06:35:20.000000000 +0000
+++ efax/Makefile.in
@@ -358,7 +358,7 @@ install-man1: $(dist_man_MANS)
echo "$$d$$p"; echo "$$p"; \
done | \
sed -e 'n;s,.*/,,;p;h;s,.*\.,,;s,^[^1][0-9a-z]*$$,1,;x' \
- -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,' | \
+ -e 's,\.[0-9a-z]*$$,-0.9a,;$(transform);G;s,\n,.,' | \
sed 'N;N;s,\n, ,g' | { \
list=; while read file base inst; do \
if test "$$base" = "$$inst"; then list="$$list $$file"; else \