pkgsrc/www/libwww/patches/patch-ab
fredb fc188fc5fc Rely on the fact that shared libraries can encode run-time dependencies
on other libraries, on both ELF and (NetBSD/)a.out, to make
libwwwssl.so.?.? depend on the correct openssl shared libraries, as
determined by the setting of ${SSLBASE} in bsd.pkg.mk. This closes PR
pkg/12570, and has the additional advantage that programs that _do_ _not_
need to link in "-lwwwssl" won't get "-lssl" or "-lcrypto" at all.

Also, make"w3c" and "www" build again with USE_SOCKS=4.
2001-04-20 12:33:52 +00:00

13 lines
378 B
Text

$NetBSD: patch-ab,v 1.9 2001/04/20 12:33:53 fredb Exp $
--- Library/src/HTMIMImp.c.orig Mon Feb 22 16:10:11 1999
+++ Library/src/HTMIMImp.c
@@ -226,7 +226,7 @@
int value = deflt;
if (start != NULL) {
start += strlen(needle);
- while isspace(*start) start++;
+ while (isspace(*start)) start++;
if (isdigit(*start)) {
char * end = start + 1;
char save;