fix PR pkg/44465 Changelog: 2010-01-08 <Jim@LS-RED> * Version 8.0 released 2010-01-05 <Jim@LS-RED> * xspim/Imakefile, spim/Makefile Jaymie Strecker [JStrecker@wooster.edu]: Change install path from /usr to /usr/local. Removed -D option, which doesn't exists on MacOS. * pervasive: Change license to a BSD license, update copyright notices, and eliminated references to my old email address. 2009-12-05 <Jim@LS1> * CPU/spim-utils.c (initialize_run_stack) [÷ý´ö´ÊîÜ® bupjae@hotmail.com]: Simplify alignment of data on stack to ensure enough room is left for environment and args at top of stack. * PCSpim/PCSpimView.cpp: Initialize stack with arguments when running program from run dialog. * spim/spim.c (read_input) [Adam Wolfe Gordon adam.wolfegordon@gmail.com}: read_input filled buffer with last character of file not terminated by newline. * Documentation/spim.html [Dave Comer dmcomer@dmcmicro.com]: Links to MIPS documentation were broken. 2009-09-22 <Jim@LS1> * spim/spim.c (main) [Ohad Kammar ohad.kammar@ed.ac.uk]: Did not return value from exit syscall. 2009-03-01 James larus <larus@ubuntu-laptop> * xspim/buttons.c [Karl Ljungkvist k.ljungkvist@gmail.com]: Step command reinitialized the stack, which changed registers (argc, argv). 2009-03-01 <Jim@LS1> * Documentation/spim.html: Updated web page to remove reference to spim source in PCSpim source distribution. * PCSpim/PCSpimView.{cpp, h}, SettingsDlg.cpp, BreakpointDlg.cpp, MainFrm.{cpp, h}: Force redisplay of data segment in situations in which register values may have changed, such as $sp. Some cleanup as well. * PCSpim/PCSpimView.cpp: Properly initialize the PC at the first invocation of the step operation. * PCSpim/PCSpimView.cpp, spim/spim.c [Pierce, Bill [pierce@hood.edu]: Initialize the stack when initializing the world, so the stack is initialized when single stepping as well as running. 2009-02-13 <Jim@LS1> * CPU/mem.c (bad_mem_write) [phong le phongle@nlsim.com]: Major memory leak: instructions overwritten by self-modifying code were not freed! * spim/Configure, xspim/Configure [Carlos Pantelides carlos_pantelides@yahoo.com]: Added test for 64 bit Linux systems. 2009-01-22 <Jim@LS1> * spim/Makefile: Fix install commands so exceptions.s is installed at /usr/lib/spim. Rerelease of spim.tar.* 2009-01-14 <Jim@LS1> * pcspim.zip: Rerelease of pcspim to correct installer problem. Visual Studio 9.0 required new crt and mfc libraries. 2009-01-01 <Jim@LS1> * Released version 7.4 2009-01-01 James larus <larus@ubuntu-laptop> * xspim/Imakefile, spim/Makefile: Fix install directories for Linux. 2008-11-29 <Jim@LS1> * xspim/buttons.c [karl.marklund@gmail.com]: Command line arguments for assembly code not properly set. 2008-11-28 <Jim@LS1> * PCSpim/PCSpimView.{cpp,h}: Command line arguments not set properly on second and subsequent runs. 2008-11-01 <Jim@LS1> * Version 7.4 * Tests/tt.core.s (madd_) Miguel Barão [mjsb@di.uevora.pt]: Added test for madd(2, -1) with (hi, lo) = (0, -1). 2008-05-18 <Jim@LS1> * CPU/scanner.l [liblit@cs.wisc.edu]: Fix for flex 2.5.33 was too specific for that version and failed on later versions, which propagated the change recoganized by fix of2005-02-05. 2007-05-20 <Jim@LS1> * CPU/run.c (run_spim): Fixed handling of borrow from subtract of low-order word in MSUB and MSUBU 2007-05-03 <Jim@LS1> * CPU/run.c Tim ODonnell [timodonnell@gmail.com]: Fixed handling of overflow from add of low-order word in MADD and MADDU. 2007-04-15 <Jim@LS1> * Documentation/spim.html: Updated MIPS documenation links to reflect new file versions. Included link to Nokia 660 port. 2007-01-14 <Jim@LS1> * CPU/inst.c (inst_decode) Cai Hongxu [caihongxu@gmail.com]: Did not correctly decode SPECIAL2 instructions (e.g., madd). 2006-08-28 <Jim@LS1> * spim/Makefile: Explicitly include exception handler path for "make test" to eliminate need to install it before running test.
39 lines
1.1 KiB
Text
39 lines
1.1 KiB
Text
$NetBSD: patch-aa,v 1.7 2011/02/05 13:38:15 ryoon Exp $
|
||
|
||
--- xspim/Imakefile.orig 2010-01-09 05:22:58.000000000 +0000
|
||
+++ xspim/Imakefile
|
||
@@ -43,13 +43,13 @@
|
||
#
|
||
|
||
# Full path for the directory that will hold the executable files:
|
||
-BIN_DIR = /usr/local/bin
|
||
+#BIN_DIR = /usr/local/bin
|
||
|
||
# Full path for the directory that will hold the exception handler:
|
||
-EXCEPTION_DIR = /usr/local/lib/spim
|
||
+EXCEPTION_DIR = $(PREFIX)/share/spim
|
||
|
||
# Full path for the directory that will hold the man files:
|
||
-MAN_DIR = /usr/local/man/en
|
||
+#MAN_DIR = /usr/local/man/en
|
||
|
||
|
||
# If you have flex, use it instead of lex. If you use flex, define this
|
||
@@ -122,7 +122,7 @@ force: configuration
|
||
configuration:
|
||
./Configure
|
||
|
||
-InstallProgram(xspim,$(BIN_DIR))
|
||
+InstallProgram(xspim,$(BINDIR))
|
||
InstallNonExec($(CPU_DIR)/exceptions.s,$(EXCEPTION_DIR)/exceptions.s)
|
||
#InstallManPage($(DOC_DIR)/xspim,$(MAN_DIR))
|
||
|
||
@@ -157,7 +157,7 @@ very-clean: clean
|
||
rm -f configuration
|
||
|
||
makedepend: y.tab.c
|
||
- makedepend -w10 -I. -I$(CPU_DIR) $(CPU_DIR)\*.c *.c
|
||
+ makedepend -w10 -I$(X11BASE)/include -I. -I$(CPU_DIR) $(CPU_DIR)\*.c *.c
|
||
|
||
#
|
||
# DO NOT DELETE THIS LINE -- make depend depends on it.
|