f377e26c1f
<mike at ethmoid dot org>. Package changes: - the vicf script is not usable as is: patch it to make it obvious and install it as an example. - switch to requiring the auto* tools at build time. - While I'm here claim stewardship (before completely removing it from pkgsrc ?). Changes in version 1.6.5: - bug fixes including a security issue with link races. - auto* tools update and commands installation directory change (overridden by this package patch files to keep it the same as previous versions and even cfengine 2.*) XXX Threads support completely removed. From my humble experience it is quite broken in cfengine 1.*. It is only used in cfd and when DCE support is enabled: the latter is not activated in this package and if the former really needs a performance/ability boost you should really consider cfengine 2.*. All in all you should not update but switch to cfengine2 package instead. ;)
66 lines
2.2 KiB
Text
66 lines
2.2 KiB
Text
$NetBSD: patch-aa,v 1.4 2003/06/19 11:45:02 seb Exp $
|
|
|
|
--- configure.in.orig 2002-08-15 05:59:16.000000000 +0000
|
|
+++ configure.in
|
|
@@ -159,17 +159,17 @@ dnl ####################################
|
|
dnl Handle DCE + threading stuff
|
|
dnl #######################################################################
|
|
|
|
-AC_CHECK_LIB(pthread,main) dnl POSIX threads
|
|
+dnl AC_CHECK_LIB(pthread,main) dnl POSIX threads
|
|
|
|
-if test "$ac_cv_lib_pthread_main" = "yes"; then
|
|
- AC_CHECK_HEADERS(pthread.h)
|
|
- AC_CHECK_HEADERS(sched.h)
|
|
-fi
|
|
+dnl if test "$ac_cv_lib_pthread_main" = "yes"; then
|
|
+dnl AC_CHECK_HEADERS(pthread.h)
|
|
+dnl AC_CHECK_HEADERS(sched.h)
|
|
+dnl fi
|
|
|
|
AC_CHECK_FUNC(lchown, AC_DEFINE(HAVE_LCHOWN))
|
|
|
|
-AC_CHECK_FUNC(pthread_attr_setstacksize, AC_DEFINE(HAVE_PTHREAD_ATTR_SETSTACKSIZE), AC_CHECK_LIB(pthread, pthread_create))
|
|
-AC_CHECK_FUNC(pthread_sigmask, AC_DEFINE(HAVE_PTHREAD_SIGMASK), AC_CHECK_LIB(pthread, pthread_create))
|
|
+dnl AC_CHECK_FUNC(pthread_attr_setstacksize, AC_DEFINE(HAVE_PTHREAD_ATTR_SETSTACKSIZE), AC_CHECK_LIB(pthread, pthread_create))
|
|
+dnl AC_CHECK_FUNC(pthread_sigmask, AC_DEFINE(HAVE_PTHREAD_SIGMASK), AC_CHECK_LIB(pthread, pthread_create))
|
|
|
|
AC_ARG_ENABLE(DCE,[ --enable-DCE support for DCE and ACLs],[
|
|
case "$enableval" in
|
|
@@ -235,8 +235,8 @@ case "$target_os" in
|
|
aix*)
|
|
AC_DEFINE(AIX)
|
|
CPPFLAGS="$CPPFLAGS -w"
|
|
- AC_CHECK_LIB(pthreads, main)
|
|
- AC_CHECK_HEADER(pthreads.h)
|
|
+dnl AC_CHECK_LIB(pthreads, main)
|
|
+dnl AC_CHECK_HEADER(pthreads.h)
|
|
;;
|
|
osf*)
|
|
AC_DEFINE(OSF)
|
|
@@ -261,8 +261,8 @@ case "$target_os" in
|
|
;;
|
|
freebsd*)
|
|
AC_DEFINE(FREEBSD)
|
|
- CFLAGS="$CFLAGS -pthread"
|
|
- AC_CHECK_HEADERS(pthread.h)
|
|
+dnl CFLAGS="$CFLAGS -pthread"
|
|
+dnl AC_CHECK_HEADERS(pthread.h)
|
|
;;
|
|
netbsd*)
|
|
AC_DEFINE(NETBSD)
|
|
@@ -301,10 +301,10 @@ case "$target_os" in
|
|
|
|
sysv4.2MP|unix_sv*)
|
|
AC_DEFINE(UNIXWARE)
|
|
- AC_CHECK_LIB(thread,main) dnl POSIX threads, weird setup
|
|
- if test "$ac_cv_lib_thread_main" = "yes"; then
|
|
- AC_CHECK_HEADERS(thread.h)
|
|
- fi
|
|
+dnl AC_CHECK_LIB(thread,main) dnl POSIX threads, weird setup
|
|
+dnl if test "$ac_cv_lib_thread_main" = "yes"; then
|
|
+dnl AC_CHECK_HEADERS(thread.h)
|
|
+dnl fi
|
|
;;
|
|
|
|
cygwin*)
|