48 lines
1.3 KiB
Text
48 lines
1.3 KiB
Text
$NetBSD: patch-aa,v 1.3 2014/12/11 22:23:19 joerg Exp $
|
|
|
|
--- src/Makefile.orig 1995-08-23 12:12:48.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -2,16 +2,16 @@
|
|
|
|
### You need a C compiler that compiles ANSI C code.
|
|
-CC = gcc
|
|
-CFLAGS = -Wall -pedantic -O
|
|
+#CC = gcc
|
|
+#CFLAGS = -Wall -pedantic -O
|
|
|
|
### If you need additional linker flags add them here.
|
|
-LDFLAGS =
|
|
+LDFLAGS = -s
|
|
|
|
### The directory where the Elk installation resides on your system.
|
|
-ELKDIR = /usr/elk
|
|
+ELKDIR = ${PREFIX}/lib/elk
|
|
|
|
### Additional libraries. You may want to insert the output of the
|
|
### shell-script $(ELKDIR)/lib/ldflags here.
|
|
-LIBS = -lm
|
|
+LIBS = -L${PREFIX}/lib ${COMPILER_RPATH_FLAG}${PREFIX}/lib -lelk -lm
|
|
|
|
### The makedepend program (it's usually installed with the X11 binaries).
|
|
@@ -19,5 +19,5 @@ MAKEDEP = makedepend
|
|
|
|
### The directory under which you will install the Scheme files.
|
|
-DIR = /usr/local/lib/unroff
|
|
+DIR = ${PREFIX}/share/unroff
|
|
|
|
### The default output format.
|
|
@@ -31,5 +31,5 @@ FORMAT = html
|
|
|
|
SHELL = /bin/sh
|
|
-INCLUDE = -I$(ELKDIR)/include
|
|
+INCLUDE = -I${PREFIX}/include/elk
|
|
ELK = $(ELKDIR)/lib/module.o
|
|
DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
|
|
@@ -68,6 +68,5 @@ OBJECTS = \
|
|
subst.o\
|
|
table.o\
|
|
- unroff.o\
|
|
- $(ELK)
|
|
+ unroff.o
|
|
|
|
ALL = unroff
|